Home Forums Plugin Support WP User Frontend Pro Dashboard Edit LInk missing

This topic is: resolved

This topic contains 12 replies, has 4 voices, and was last updated by  Tareq 1 year, 6 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1852
    strangerrj
    Post count: 82

    Hi,

    since the last update, the Edit link from the dashboard no longer there. Everything is turned on in the back and nothing has changed.

     

    Cheers

    #1857
    Key Master
    Tareq
    Post count: 2807

    Oops, sorry. I’ll fix this. Right now you can fix it quickly by going to /class/frontend-dashboard.php line 156. Change wpuf_payment to wpuf_dashboard

    #1860
    strangerrj
    Post count: 82

    oh thands for the answers.

    cheers

     

     

    #1866
    sebiferi
    Post count: 9

    Correct solution:

    Change line 156 to this:

    if ( wpuf_get_option( ‘enable_post_edit’, ‘wpuf_dashboard’, ‘yes’ ) == ‘yes’ ) {

    #1867
    strangerrj
    Post count: 82

    thank you.

    cheers

    #4873
    jman057
    Post count: 16

    Hi Tareq,

    I have the described problem; no link to ‘edit’ showing in the dashboard, just an empty space where it should be. I have enabled editing in the settings and have provided the location of the page with the edit shortcode, but it’s not showing up. I looked at the solution above but it did’t solve the problem, looked like line 156 may not be the right place to insert this code, as that line is already there on 173.

    Wordpress latest version fresh install, just brought the plugin last night, looks great!

    Thanks!

    #4875
    Key Master
    Tareq
    Post count: 2807

    Can you describe what steps did you take to setup the dashboard and edit page?

    #4907
    jman057
    Post count: 16

    Sure.

    I have a page for the dashboard with only the shortcode: [wpuf_dashboard]
    I have a page for editing, with only the shortcode: [wpuf_edit]

    In User Frontend/Settings/General Options, I have checked the box: Override the post edit link. Have tried with this on and off
    In User Frontend/Settings/Dashboard, I have selected “yes” for: Users can edit post? and User can delete post?

    Payment options are off

    As this is essentially a test site for my real one, I have added a user profile that I can share with you:

    Username: Tareq
    Password: temp1234
    Admin: researchstudies.com.au/wp-admin

    There is nothing on the site that is important and I will remove the login once this issue is resolved. You may note that haven’t yet activated the plugin, that is because I am saving that for my real site.

    Thanks!

    Jamie

    #4909
    Key Master
    Tareq
    Post count: 2807

    The login info doesn’t work. Can you recheck? and please post the login details as a private reply.

    #4910
    jman057
    Post count: 16
    This reply has been marked as private.
    #4911
    Key Master
    Tareq
    Post count: 2807

    You just had to save the dashboard setting in the plugin once again :)

    #4912
    jman057
    Post count: 16

    Thanks! Sorry for taking your time on this, I had tried for sometime last night to fix it and just couldn’t figure it out. Now I know for next time.

    Thanks!

    Brilliant plugin too, I’m excited about what this could do for my website!

    #4913
    Key Master
    Tareq
    Post count: 2807

    Please leave us a testimonial if you could :)

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.