This topic contains 4 reply and 2 voices, and was last updated by towhid 4 years, 7 months ago
Viewing 4 Posts - 1 through 4 (of 4 total)
Author Posts
March 17, 2015 at 1:42 am 39271
towhid I've tried:
  • Disabling Addons
  • Adding code to the functions.php
  • if ( current_user_can('author') && !current_user_can('upload_files') )
    add_action('admin_init', 'allow_contributor_uploads');
    function allow_contributor_uploads() {
    $contributor = get_role('author');
    $contributor->add_cap('upload_files');
    }
  • Clearing website and browser caches
It's only an issue with the "Add Media" button with the user role set to author. I have limited the Author access to the dashboard which may conflict, but using the code I entered it should bypass any conflicts. However if I use the attachment button at the bottom, it will upload the image to be used in a later post. (But doesn't attach it to the current.) Please assist.
March 17, 2015 at 1:43 am 39272
Rachel Reviczky Rachel Reviczky

March 19, 2015 at 7:18 pm 39534
towhid towhid

Hello Rachel,

Please allow me some time to produce this feature for myself. I will be come back as soon as possible.

Thank You:)

March 20, 2015 at 1:55 am 39555
Rachel Reviczky Rachel Reviczky

Hi there,

Sorry I forgot to update that I resolved this issue..

For those who experience this specific issue, all I needed to do was get an addon to edit the author permissions and change the permissions to include all of the following:

edit_others_pages
edit_others_posts
edit_pages
edit_posts
edit_published_pages
edit_published_posts
publish_pages
publish_posts
read
unfiltered_html
unfiltered_upload
upload_files

Not all are enabled by default on the Author account which can cause some conflicts.

March 21, 2015 at 9:50 am 39631
towhid towhid

Hello Rachel,

I am very glad to know the problem has been solved by you. Hope this topic might be helpful for someone if they face this kind of experiences. I am going to mark this topic as resolve.

Thank You 🙂

Viewing 4 Posts - 1 through 4 (of 4 total)