Home Forums Theme Support Dokan Paypal adaptive settings

This topic is: not resolved

This topic contains 39 replies, has 2 voices, and was last updated by  Nayem 3 years, 11 months ago.

Viewing 15 posts - 1 through 15 (of 40 total)
  • Author
    Posts
  • #54449

    Erik
    Member
    Post count: 29

    Hi,

    I am very confused by the paypal adaptive settings, the documentation is also not that clear to me.

    So from paypal I get (replaced some chars with XXXX):

    Application (REST API apps):
    PayPal account: hi@xxxxxx.com
    1. Client ID: AYVTXXXXXXXXXXXYRZXXXXXXXXXXXXXXXXXXXXXqIxXXXXXXXXXOo_ak
    2. Secret: ELyT51MW06qbyvXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXTFoGXvtR0F7v57tq

    API
    3. API Username: hi_api1.XXXXXXXX.com
    4. API Password: LYXXXXXXXXXXXXMA
    5. Signature: AUBXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXM1ilXXXXXXfL6XD4C

    In the plugin I set:
    App Username (3. API username)
    App password (4. API Password)
    App Signature (5. Signature)
    API App ID (1. Client ID)

    • My app is active and approved.
    • No idea if I am entering the right thing in the right forms ๐Ÿ™‚
    • Always get the same error: This transaction is invalid. Please return to the recipient's website and try again.
    • The seller has set his paypal address in: http://www.XXXXXXXX.com/dashboard/settings/payment/

    Are the settings as I am setting them correct (I guess not), how to set them?

    #54452

    Erik
    Member
    Post count: 29
    This reply has been marked as private.
    #54590

    Nayem
    Moderator
    Post count: 6480

    Hello,

    When you will add a product into the cart, you have to make sure that that seller has valid PayPal or he configured his account in his dashboard settings. Please check for this and let me know. Wrong credential and invalid seller account is the reason for this error.

    #54602

    Erik
    Member
    Post count: 29

    Hi Nayem,

    Yes, see above, the paypal is added here:
    The seller has set his paypal address in: http://www.XXXXXXXX.com/dashboard/settings/payment/

    Is there another place it should be set or is this the one?
    The rest of the settings seem ok to you?

    Thanks!

    #54612

    Nayem
    Moderator
    Post count: 6480

    Yes, your rest settings are correct. If you can then check with Paypal sandbox account.

    #54615

    Erik
    Member
    Post count: 29

    OK will do, but I see that about 3 hours ago you started with: https://wedevs.com/support/topic/permalinks-index-php/
    So now the site is not working, I will wait till that is done and I will continue further with this then.

    #54621

    Erik
    Member
    Post count: 29

    Hi,

    So in sandbox mode I get the exact same error.

    #54690

    Nayem
    Moderator
    Post count: 6480

    Hello Erik,

    I will check with site with my sandbox data.

    Please provide your login details by using this form: http://wedevs.com/provide-login-details/.

    Thank you ๐Ÿ™‚

    #54714

    Erik
    Member
    Post count: 29
    This reply has been marked as private.
    #54720

    Nayem
    Moderator
    Post count: 6480

    ok. Please allow me some time to check.

    #54725

    Erik
    Member
    Post count: 29
    This reply has been marked as private.
    #54730

    Nayem
    Moderator
    Post count: 6480

    When I was trying to place an order I got this error- Invalid user id. I saw that you have customize something in the plugin file. Please let me know the entire scenerio.

    Thanks.

    #54732

    Erik
    Member
    Post count: 29

    Hi Nayem,

    In Dokan I only changed the menu and added the add product button to the main dashboard.
    However, this problem was first encountered on a completely clean install.

    #54737

    Nayem
    Moderator
    Post count: 6480

    Hello,

    Please select parallel payment system and then check. Everything will work fine.

    #54744

    Erik
    Member
    Post count: 29
    This reply has been marked as private.
Viewing 15 posts - 1 through 15 (of 40 total)

The topic ‘Paypal adaptive settings’ is closed to new replies.