Home Forums Plugin Support WP Project Manager Pro Update of Project Manager Pro won't complete

This topic is: not resolved

This topic contains 24 replies, has 5 voices, and was last updated by  Nayem 3 years, 9 months ago.

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #70863

    Thomas
    Member
    Post count: 8

    Was just shy of launching my first WordPress blog and made the mistake of searching for and running updates to all of my plugins. Project Manager Pro is the one that broke. In the Plugin manager of WP-Admin I have a message that says “Project manager Data Update Required โ€“ Please click the button below to update to the latest version.” Clicking the indicated button refreshes the page but otherwise does nothing. PM Pro shortcodes now produce random results depending on the page (they used to work) and nothing at all on new pages.

    I am on WP 4.3 and I notice that PM Pro is “Compatible up to WP 4.2”. Had I noticed that earlier I wouldn't have upgraded, so my bad. Can I please get:

    • An idea of when you will be supporting v4.3?
    • How to back this out without losing my project data?

    I put a lot of time into building 5 interrelated projects, and I would prefer to use a workaround like inline spreadsheets to display project info until you release an update. Aside from the stuck data update notification, all the other problems seem to be on the front end, so I am assuming my project data is actually intact.

    Thank you,
    Tom

    #70871

    Sam
    Member
    Post count: 2

    Hey there PM,

    I am having the same issues as stated above. Have we come up with a resolution yet? I'd really appreciate it if we can get an update as soon as possible.

    Thank you,
    Sam

    #70885

    Nayem
    Moderator
    Post count: 6480

    Hello Thomas,

    We have released a new update for Project Manager Pro. The latest version is v1.3 which is compatible with the latest version of WP. Please update your plugin to the latest version. After updating to the latest version if you are getting any issue then let me know. We will fix it within 24 hours.

    Thanks.

    #70908

    Thomas
    Member
    Post count: 8

    Thank you for the response. It was the upgrade to 1.3 that got me into this mess in the first place. I tried deactivating and removing PM Front-End, then reinstalled and reactivated it. I got the PHP “white screen of death.” I solved that by walking to the plugin directory for PM Front-end and removing it.

    I can reproduce the following sequence reliably:

    Pre-condition: Deactivate and remove Project Manager and Project Manager Front-end. WordPress V4.3.
    1: Install Project Manager Pro 1.2.2 and activate it. Note that after the first time, it no longer asks for a key.
    2: Install Project Manager Front End 1.2.1 and activate it.
    3: On any page, attempt to use the front end shortcodes. These no longer function after my original upgrade attempt. eg: [cpm] only brings up the message “Project created by Tom – September 4, 2015 2:20 pm” (there are 5 projects) when the page is viewed from the admin dashboard after editing. If the page is navigated to on the live site, there is no CSS loaded for the page at all. More elements of the PM front-end show, but all formatting is gone.
    4: Allow the Project Manager to upgrade to 1.3 by selecting upgrade in the plugin manager. This produces a message at the top of the plug in manager that says “Project manager Data Update Required โ€“ Please click the button below to update to the latest version.” Clicking the button does nothing, and the message persists.
    5: Deactivate the Front-end plugin and attempt to re-activate it again. This results in the message: “Fatal error: Cannot redeclare class CPM_Frontend in /home1/woodsnet/public_html/wp-content/plugins/wedevs-project-manager-frontend-pro/frontend.php on line 43”

    From here, I did the following:

    1: Deactivated and removed the 1.2.x versions of Project Manager Front-end and Project Manager.
    2: Installed the version 1.3 Project Manager directly. I was happy to notice I still had my projects. There is no more message about needing to upgrade data.
    3: Checking the page with shortcodes, which I didn't remove, reveals no CSS as before.
    4: Removing the shortcodes restores the page.
    5: I don't see a later version of PM Front-end than 1.2.1, so I reinstall 1.2.1 and get the same fatal error on activation. I have remove it to restore my page formatting.

    So, I think WP Project Manager seems to be fine when installed directly vs. upgrading in the Plugin Manager, but the whole front-end piece is broken. Is there a new Front-End for the project manager or is the front-end stuff built-in maybe? Have the codes changed?

    Thank you!
    Off to bed now, I have work in a few hours.
    Tom

    #70913

    Nayem
    Moderator
    Post count: 6480

    Please provide your login and FTP details by using this form: http://wedevs.com/provide-login-details/. I will update the project manager pro plugin and will fix those errors.

    Thank you ๐Ÿ™‚

    #70990

    Sam
    Member
    Post count: 2

    Hi Nayem-

    I've submitted my information for you to login and correct the issue.

    Thank you,
    Sam

    #71080

    Nayem
    Moderator
    Post count: 6480

    @sam your username or password is not working. Also you did not provide your FTP details. Please provide your FTP details also.

    @thomas, I am waiting to hear from you. I have asked for your site details.

    #71285

    ray
    Member
    Post count: 1

    I had the same problem. It seems that is fixed now – hopefully for good.
    I just deactivated the plugin and then activated it back. No data lost ๐Ÿ™‚

    Thomas: you wrote: “5: I donโ€™t see a later version of PM Front-end than 1.2.1, so I reinstall 1.2.1 and get the same fatal error on ”
    If you already have the frontend add-on installed, please delete that before updating. Because the add-on and plugin will conflict because of same features.

    #71354

    Thomas
    Member
    Post count: 8

    That was a good idea, Ray. I removed everything and just installed PM Pro 1.3 fresh. It did change the behavior. Now a short code like [cpm id=””] will bring back the project activity page, but that's it. None of the other tabs show. the catch-all [cpm] shows a tile for each of my five projects, but selecting any one only shows the project activity page, with no other tabs revealed.

    I consider this to be progress though. Either I really broke something and need surgery or there is a new incompatibility with my theme or some other plugin. I'm going to proceed by disabling other plugins until something changes.

    #71402

    Nayem
    Moderator
    Post count: 6480

    Hello Thomas,

    I have asked for your details a couple of times. We will fix this issue. Please send your login and FTP details by using this link- http://wedevs.com/provide-login-details/.

    #71574

    Thomas
    Member
    Post count: 8

    Yes, I did that, a couple of days ago. I then came back to this forum and told you about it, but now I do not see my post. I'm not sure what happened, but I will go and do it again

    #71575

    Thomas
    Member
    Post count: 8

    Ok, I have posted my credentials again. As I explained in the lost post, I have tested the FTP credentials with Cyberduck. My ISP has an unusual username format and I've never figured out how to construct a working ftp session from the shell, but Cyberduck and other GUI programs seem to work well. Let me know if you have problems.

    Also, you request a “Website username and password.” I assume this means for WordPress, but if what you really mean is shell or database access, let me know and I will raise a ticket with my ISP to get you a shell account.

    Thank you Nayem. I hope this post stays put.
    Tom

    #71576

    Nayem
    Moderator
    Post count: 6480

    Hello Thomas,

    We have released a new update which is v1.3.1 with the fix. Please update your plugin to the latest version. Also, do not activate Project Manager Frontend add-on because we have included frontend feature with the main plugin.

    Thanks.

    #71616

    Thomas
    Member
    Post count: 8

    I have completely removed the old Frontend add-on.

    I am not having a great deal of success here. Here is what I have tried.

    1: Starting from my existing 1.3 installation, I am trying to get the plugin to recognize that is has an update. WordPress has the update flag icon on the sidebar with “1” available update, but no plugin, including PM Pro has an update now link. Checking the box next to PM Pro and going to bulk actions does not cause an update (WP reports that the plugin is already at the most recent version.) The refresh button in the top menu shows the number 1, hovering over it gives a tool tip of “1 plugin update”, but clicking it brings up the update status that says “Your plugins are all up to date.”

    2: Deactivated and re-activated 1.3. No change.

    3: Removed and reinstalled and re-activated 1.3 – No change.

    4: Removed 1.3, re-installed 1.2.2, and was able to update to the new 1.3.1, however, the message โ€œProject manager Data Update Required โ€“ Please click the button below to update to the latest version” is back, and just like before clicking on the button does nothing.

    5: I uninstalled 1.3.1 and reinstalled and re-activated 1.3 to try to continue fishing for a way to get it to allow the upgrade. Is there some place I can download a 1.3.1 Zip from? I'll mention that the symptom of front-end display issues previously described has not changed. I still can't see anything except a project activity list. This was consistent with every step above, except for the brief time I had 1.2.2 installed and thus had no frontend support.

    I even tried switching out the theme and got the same exact rendering result. So this is where I'm leaving it for now, on 1.3 with no way to kick off an upgrade.

    -Tom

    #71617

    Nayem
    Moderator
    Post count: 6480

    Hello Thomas,

    Please make sure that you have activated your license key in your site. Otherwise you will not get the auto update.

    You can download the latest version of Project manager from your account (wedevs.com/account). After downloading the latest version, install it to your site. After installing the latest version you have to insert the license key again. Now, the thing is- if you have activated your license key before then you will not be able to activate the license again.

    No need to worry about the activation problem. We will reset your activation then you will be able to activate the license again.

    Please contact with us by using this contact form- http://wedevs.com/contact/. You have to select the question type as- “License activation problem”. We will solve your license issue as soon as possible.

    Thank you ๐Ÿ™‚

Viewing 15 posts - 1 through 15 (of 25 total)

The topic ‘Update of Project Manager Pro won't complete’ is closed to new replies.