Home Forums Theme Support Dokan Variable product not working properly

This topic is: not resolved

Tagged: 

This topic contains 21 replies, has 2 voices, and was last updated by  Nayem 3 years, 7 months ago.

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #73128

    Siwoo
    Member
    Post count: 16

    Hello there,

    I was trying to add a variable product but update & delete variation is not working.
    What I've figured out is my website's url of product edit page is different from dokan demo website's url.
    Mine look like product/product name/edit/ but it suppose to be like product/?product_id=123&action=edit
    Please advice me the correct permalink setting.
    Currently WordPress -> Post name & WooCommerce -> Product

    #73268

    Nayem
    Moderator
    Post count: 6480

    Hello Siwoo,

    Are you able to edit the product from the frontend? Also you have to make sure that you have changed your permalinks correctly.

    Thanks.

    #73340

    Siwoo
    Member
    Post count: 16

    My permalinks setting are like this:

    common settings -> post name
    product permalink base -> custom base (/product)

    I've tried to change product permalink base from “custom base” to “product” but it won't change.
    so I just set the custom base as “/product”

    does it make the problem?

    I can edit products from the frontend but it seems editing variables not working properly.
    I think it's the permalink problem.

    Because on the sample site,
    the product edit link looks like: product/?product_id=123&action=edit

    but on my site,
    product/product name/edit/

    why this happend?

    #73352

    Nayem
    Moderator
    Post count: 6480

    Please provide your login details by using this form: http://wedevs.com/provide-login-details/. I will have a look what is going wrong.

    Thank you ๐Ÿ™‚

    #73354

    Siwoo
    Member
    Post count: 16

    just sent login details. please check.

    #73366

    Nayem
    Moderator
    Post count: 6480

    Hello,

    I have checked your site and I can easily this product which is a variable product- http://bigmart.co.nz/?post_type=product&p=2971. I did not get any error.

    Thanks.

    #73373

    Siwoo
    Member
    Post count: 16

    if you login as an admin, there is no problems at all.
    but please try to login as a vendor.

    then you will see all the problems I said.

    #73376

    Nayem
    Moderator
    Post count: 6480

    I will check again. Please allow me some time.

    #73424

    Nayem
    Moderator
    Post count: 6480

    I have forwarded your issue to our developer team. They will fix this issue within tomorrow.

    Thanks.

    #73425

    Siwoo
    Member
    Post count: 16

    Thanks. I hope it will be fixed soon.

    #73511

    Nayem
    Moderator
    Post count: 6480

    Please check your site. I have tested and everything is fine now.

    #73518

    Siwoo
    Member
    Post count: 16

    No. it still have the same problems if you login as a vendor.

    Firstly,
    Title and Breadcrumb are disappeared when you edit a product.

    Products list:
    http://prntscr.com/8m2sez

    When you edit, it's disappeared:
    http://prntscr.com/8m2sow

    Secondly, for the variations,
    if you create many variations and save them and come back to delete some of them,
    it doesn't work at all. You can't delete the variables.

    There is no problems at all if you login as an admin.
    If you login as an admin, there is no permalink problems.
    so all work fine.

    but if you login as a vendor,
    lots of problems occur.

    I strongly doubt this happens because of permalink problem on your code.

    I think this is a very serious problem for dokan.
    please check deeply.

    #73520

    Siwoo
    Member
    Post count: 16

    Look at this. the url shouldn't be like that.

    http://prntscr.com/8m2ufb

    it should be something like this:
    product/?product_id=123&action=edit

    if you login as an admin, it works fine but login as a vendor the problem occurs.

    #73550

    Nayem
    Moderator
    Post count: 6480

    Please provide your FTP details here.

    #73551

    Nayem
    Moderator
    Post count: 6480

    Hello,

    Your variable product edit or delete problem has been fixed. You have mentioned few design issue which about breadcrumb. I think you have customized the dashboard page and for this reason those css messed up. We can not help for this because the page is customized already.

Viewing 15 posts - 1 through 15 (of 22 total)

The topic ‘Variable product not working properly’ is closed to new replies.