Home Forums Theme Support Dokan Fresh install of wordpress, wooCommerce and dokan not working

This topic is: not resolved

This topic contains 16 replies, has 2 voices, and was last updated by  Nayem 4 years, 2 months ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #44551

    Milan
    Member
    Post count: 9

    Steps followed when installing WordPress, WooCommerce and Dokan

    1. Install wordpress
    2. Delete ‘Hello world’ post and comment
    3. WP settings … enable ‘Anyone can register’
    4. Plugins -> add new … search for WooCommerce and install
    5. I click activate
    6. WooCommerce -> settings … Set base location to new zealand, selling to new zealand, currency new zealand dollar
    7. Plugin -> add new -> upload plugin … I choose dokan-plugin-2.2.1.zip and click install now
    8. I click activate
    9. I click enter dokan licence and then enter email address and licence key, then save & activate
    10. Appearance -> themes -> add new -> upload theme … I choose dokan-theme-v2.1.1.zip and click install now
    11. I click activate
    12. Settings -> permalinks … I select ‘post name’ for Common Settings and ‘product’ for Product permalink base, and then save changes
    13. Products -> categories … I create 1 category called general (for testing)
    14. Pages -> all pages … (only 3 exist, dashboard, my orders, store list). I go into each and set the template to ‘Full-width Page’

    At this point I log out as admin and try to register as a seller.

    There are a number of problems from this point on.

    The Log in and Sign Up links in the top right of the screen do not work. I have managed to get past this point by going into woo commerce tools and create pages, but then I start getting duplicate dashboard, etc.

    Also once I do get to register as a seller, I was seeing a number of other errors, like when trying to upload a new product.

    I have tried installing everything (wordpress, woocommerce & dokan) more than 5 times already, going around in circles trying to make this work, but with no luck.

    I have now deleted everything and installed it based on the steps 1 – 14 above and have stopped there before creating more duplicates.

    Can someone please have a look at this as I am unable to proceed. The website is http://mamalish.com

    Thanks

    #44556

    Nayem
    Moderator
    Post count: 6480

    Hello Milan,

    You have done all the things correctly but you did not install WooCommerce pages. So i have done with that. Please check your sign up option now. It is working fine.

    Thank you.

    #44561

    Milan
    Member
    Post count: 9

    Hi Nayem.

    Thanks for the quick response.

    I have done that in the past which made it work, however I ended up with duplicate pages.

    I actually read on another support forum post that we should ignore creating wooCommerce pages as dokan will create its own. Thanks for this.

    My first glitch I've found it that when I try to create a new product as a seller, the link to upload a product image does not do anything. Have I missed something?

    Also something else I have picked up, is that if I use google chrome, I can't register. I can get to the my-account page. I enter an email address, password, select I am a seller, and click register, but nothing happens.

    Again, thanks for your help and quick response.

    Kind regards
    Milan

    #44567

    Nayem
    Moderator
    Post count: 6480

    Hello,

    Please make sure that you are using the latest version of Dokan theme. Download and install the latest theme.

    #44569

    Milan
    Member
    Post count: 9

    I have theme v 2.1.1 installed and it is the latest version?

    Thanks

    🙂

    #44580

    Nayem
    Moderator
    Post count: 6480

    Hello Milan,

    I have found the problem. I have forwarded this to our developer hope they will fix it as soon as possible.

    Thanks.

    #44584

    Milan
    Member
    Post count: 9

    Thanks Nayem

    It is the evening here so I will continue testing tomorrow and let you know if I find any other glitches.

    Thanks again for all your help.

    🙂

    #44643

    Nayem
    Moderator
    Post count: 6480

    Your ftp is not working. Please provide us valid ftp details.

    Thanks.

    #44648

    Milan
    Member
    Post count: 9

    I have just tried it again and it works for me .. maybe I typed it in wrong … I will submit it again

    #44652

    Milan
    Member
    Post count: 9

    I have submitted the original ftp again, and also created a new one called dokan and submitted this also. I have just test both and they both work for me.

    Hope that helps.

    #44657

    Nayem
    Moderator
    Post count: 6480

    I am really sorry to say that also this time i am not able to connect with your server.

    Here is the screenshot-

    #44710

    Milan
    Member
    Post count: 9

    have you tried port 21?

    #44712

    Milan
    Member
    Post count: 9

    I am using cyberduck on mac for testing. I will boot up an old windows pc and install FileZilla and give that a try.

    #44713

    Milan
    Member
    Post count: 9

    ok interestingly I get the same error with FileZilla … I will try find the problem and let you know how to get around it

    #44714

    Milan
    Member
    Post count: 9

    ok so the problem is that the security certificate has expired … you need to do a plain ftp connection and not one over TLS …

    In FileZilla, go to File -> Site Manager …

    create a new site.

    Under encryption, select “Only use plain FTP (insecure)”

    Click connect and it will work.

    This is only a testing server so I will look into the SSL certificate when I get a chance, but you should be able to proceed like this.

    Hope this helps.

Viewing 15 posts - 1 through 15 (of 17 total)

The topic ‘Fresh install of wordpress, wooCommerce and dokan not working’ is closed to new replies.