This topic contains 30 reply and 5 voices, and was last updated by MDelcour 4 years, 11 months ago
Viewing 15 Posts - 1 through 15 (of 30 total)
Author Posts
September 23, 2014 at 5:45 pm 27305
MDelcour Hi, I've just come across a big problem after setting a site live. I've got a number of Multiple Select fields in my registration form (Interests, Experience, Employment Status) with each having 10+ options. On editing the form to add extra options and to edit a few after saving the form all of a sudden each separate Multiple Select field has all of the options from Multiple select all fields. E.G. How it should be: Interests: Cardiology Dentistry Dermatology Experience: Local Tv Local Press Medical Press Employment status: Full time Part time What it is doing incorrectly: Interests: Cardiology Dentistry Dermatology Local Tv Local Press Medical Press Full time Part time Experience: Cardiology Dentistry Dermatology Local Tv Local Press Medical Press Full time Part time Employment status: Cardiology Dentistry Dermatology Local Tv Local Press Medical Press Full time Part time I'm now wondering if the end client when editing this has used a character that the form does not like. Earlier in development I found that entries with certain characters like commas made things go wrong with saving. Your help would be appreciated. The site has just gone live to 450 members and marketing material has been sent out to promote them logging in and setting their profile fields. Thanks, Nick.
September 23, 2014 at 5:51 pm 27306
Nick Nick

I’ve also just found it’s not limited to multiple select fields but also checkbox fields.

So now where I have a couple of simple options like ‘Hide my email address from other users’ which should have a single check box I’ve now got about 100 items selectable.

Major problem. I can’t see what’s suddenly caused this.

Please let me know if I can directly email you a username and password to login and see the issue.

Thanks,
Nick.

September 23, 2014 at 6:06 pm 27307
Nick Nick

Ok. Can you please tell me what characters you can’t use in fields?

Would an ampersand & or hyphen – or other character like that cause this?

September 23, 2014 at 6:48 pm 27309
Nick Nick

FYI I’m on WordPress 4.0 and have a number of plugins installed.

Also I should have said that this error is occuring in both the WP admin area to admin the plugin forms and the frontend profile editing page.

September 24, 2014 at 8:28 pm 27450
Sekander Badsha Sekander Badsha

Hello Nick,
Please deactivate all your plugins except User Frontend Pro and switch to a default theme of WordPress like – twenty fourteen and see if the issue solves.

If your issue is not solved after trying the above, write your admin login credentials in a private reply.

September 25, 2014 at 5:18 am 27478
Jessica Jessica

I am having the exact same issue on a brand new wp install on my local host, new database, default wp theme and this is the only plugin. Radio button fields and checkbox fields are duplicated in admin screen when you click the Update button and consequently in the exported .json.

Form doesn’t seem to have anything unusual about it. I note that:

1. some meta key fields end in _
2. Some meta key fields are very long
3. Some help text fields contain . ‘ ( ) and , characters
4. Some label name fields contain ‘?’

Jess

September 25, 2014 at 4:32 pm 27497
Nick Nick

Hi,

Thanks for your response Sekander. And Jess.

I have done a load of testing. And have not been able to resolve the problem:

Deactivate all other plugins.
Switch to 2014 WP theme.
Made sure all plugins are up to date.

The issue still persists.

I’ve also found a another problem that I presume is linked. Editing users profiles as a top level admin through the WP dashboard I cannot alter email addresses. On clicking Save the profile screen refreshes but email remains the same.

Another completely separate issue I should point out. My site name includes an apostrophe. This breaks the import and export feature. The export tool names the export file based on the site name. So it needs some sort of filter to remove these types of characters.

I will do a private reply in a second with a username and password and link to login.

Thanks,
Nick.

September 25, 2014 at 4:47 pm 27498
Nick Nick This reply has been marked as private.
September 25, 2014 at 4:55 pm 27500
Nick Nick

Hi,

Also I’ve done some further testing. I did have a couple of old versions of registration forms which were redundant but still published. I’ve deleted these but still no change to the problem.

I had though reinstating the form from a backup was resolving the issue for the moment. In terms of the profile fields not displaying incorrectly. And this is the case for the front edit users editing their profiles. But for WP admins in the WP dashboard the incorrect field options are displaying.

Nick.

September 26, 2014 at 3:57 am 27563
Jessica Jessica

My form looks exactly the same front end as backend (repeated fields, fields missing) so the form is unusable. In fact when I click Update button, entire fields are being removed.

If I export the form, correct it, and import it, the Update button continues to corrupt the form.

@wedevs do you have any idea what’s going on? Could the plugin be incompatible with the latest version of WordPress?

@nick nice design work your company does.

September 26, 2014 at 2:11 pm 27574
Nick Nick

Hi,

Yesterday after not being able to resolve the problem myself and not getting a further response here in the forum I bought an additional developer license in order to get some priority support direct via email.

I’ve not heard anything back via email nor here in the forum. I would like to receive conformation from the general support forum admin that my priority support request is actually being looked at by priority support.

It’s now been four days that a professional site for one of my clients has been broken. And the fundamental basics of managing site subscribers is pretty much useless.

I’d appreciate a response and reassurance that this issue is being resolved.

Many thanks,
Nick.

@Jessia thanks for the positive feedback.

September 27, 2014 at 9:04 am 27599
Jason Jason

Thanks for posting this Nick. I’m having the same problem on my form.

In addition, this same problem also occurs on the plugin’s demo site, so I believe the problem is with the plugin and not with the theme or other incompatible plugins.

Looking forward to having this issue resolved.

September 27, 2014 at 12:59 pm 27609
Sekander Badsha Sekander Badsha

Hello All,
Sorry for the inconvenience. Open form.php which located inside “wp-content/plugins/wp-user-frontend/admin/” and go to line number 1399. You will see something like

if ( array_key_exists( 'options', $field_val) ) {
                foreach ( $field_val['options'] as $options_key => $options_value ) {

press enter to add a new line and paste $view_option = array(); so it will look like

if ( array_key_exists( 'options', $field_val) ) {
                $view_option = array();
                foreach ( $field_val['options'] as $options_key => $options_value ) {

Let me know if you feel confused or need more detailed instruction.

September 27, 2014 at 3:41 pm 27614
Nick Nick

Hi Sekander,

Thanks for posting that fix. I’ve applied it and it’s solved most of the problem. But not all of it.

Editing the form through User Frontend works. And submitting updates for the users from the public front end works.

However the WordPress Users admin is still wrong. If I go into WP admin > Users and edit profiles the multiselect and checkbox items are all still showing incorrectly. The fields are showing all of the options for each and every field that is a check box or multiselect.

I’ve been testing this in both my test site and live version. And there seems to be a slight variation in the error between the two. On the live version if I edit a users email address through the WP User admin it will not save the change in email address and multiselect options are defaulting to a blank value – removing the options a user has already set.

The login to my test site is still available as detailed in my earlier post if you are able to test it.

Thanks,
Nick.

September 28, 2014 at 3:27 pm 27659
Sekander Badsha Sekander Badsha

Sorry for the inconvenience. The profiles you are talking about must be created while the problem was there. So, please check with a newly created user to check about the repeating fields.

And about the mail update issue: we are not doing anything in the wp-admin. So you should not face such problem. If you still suspect, you may disable WPUF and check again.

September 29, 2014 at 2:25 pm 27711
MDelcour MDelcour

We are having the same problem on our website. multiselect,radio buttons, checkbox and select fields are fusing together and some are disapearing.

I will try your solution and check if it may solve the problem

edit:
It didn’t solve my problem on the following page:http://www.brazilexpat.com/add-a-new-property/

Viewing 15 Posts - 1 through 15 (of 30 total)