This topic contains 6 reply and 3 voices, and was last updated by adamt19 6 years, 8 months ago
Viewing 6 Posts - 1 through 6 (of 6 total)
Author Posts
September 16, 2013 at 8:18 am 8203
adamt19 I've turned off all plugins, and switched to the twentytwelve theme. I've tried "Featured Image", "Add Image" and "Post Body w. image": None of these work. They either fail with "Something went wrong", or the uploader progress disappears and images never attach. I can submit posts without images just fine. YES. Max image size is set.. What's wrong here? I can post user login/password privately if needed.
September 16, 2013 at 8:23 am 8206
adamt19 adamt19 This reply has been marked as private.
September 16, 2013 at 8:37 am 8207
Tareq Hasan Tareq Hasan

I went to test that form and I was getting the ajax response as error. Then I tried to upload from wp-admin/media and here’s what I got:

non writable

Your upload directory is not writable and WordPress can’t create a directory to upload photos there

September 16, 2013 at 9:13 am 8208
adamt19 adamt19

What should permissions be on ‘uploads’?

Permissions on the uploads folder were 755, owned by root instead of www-data.

I changed to owned by www-data and 777, and I can now upload images. But I feel like the 777 is overkill/unsafe.

September 16, 2013 at 11:12 am 8212
Mahi Mahi

Its more likely server side issue. Ask your server management about it. Its not WordPress friendly environment.

September 16, 2013 at 11:26 am 8213
adamt19 adamt19

It was just a permissions issue on the uploads folder. Everything works now. It’s my server (linode)

September 16, 2013 at 12:47 pm 8216
adamt19 adamt19

I should correct myself – the images uploaded through “image upload” and the images uploaded through the message body feature work. They show up in the media tab, and you can see them attached to individual posts in the admin.

HOWEVER – the ‘featured image’ upload isn’t behaving as expected. The images arrive in “media” but there is no featured image when you ‘edit’ the uploaded post. There is seemingly no association between the post and the image, in the admin area at least.

Is this expected? I see the uploaded image if I choose “edit” to edit the original upload form. But when viewing the post from the admin area, or if viewing the approved post via slug — there’s no featured image.

Viewing 6 Posts - 1 through 6 (of 6 total)