Home Forums Plugin Support WP User Frontend Pro Pmp add-ons

This topic is: not resolved

This topic contains 30 replies, has 5 voices, and was last updated by  Sekander Badsha 4 years, 7 months ago.

Viewing 15 posts - 16 through 30 (of 31 total)
  • Author
    Posts
  • #32205

    Nayem
    Moderator
    Post count: 6480

    Hello Wayne,

    I logged in to your site. In membership levels you did not enable membership expiration. Also you have to edit user profile. In “Edit user” page you will see “Membership Levels” option. You have to set the expire date there. I am providing you both pages screenshot and i marked those place with red color.


    Thank you ๐Ÿ™‚

    #32218

    Wayne
    Member
    Post count: 22

    Nazmul,

    We actually have put the expiration in the “Free Trial” membership level
    and it still doesn't work. We have several people that have set up
    accounts and they are not working properly.

    Thanks

    Wayne Kendrick
    603-247-7220

    http://www.linkedin.com/in/wkendrick/

    #32692

    Ahmed
    Member
    Post count: 22

    Hello,

    I'm also having the same issue. I've set the expiration dates etc and reviewed all the settings carefully and read the numerous posts on this forum about the subject.

    I can confirm that Ive set all the settings both in WPUF and the Memberships correctly including expiry.

    The plugin simply doesnt work.

    My install is a new wordpress install with the latest version of FREE Membership Pro.

    ALSO, theres a bug with User Front End when you add a Google Map to a form where it will display a second copy of the Map randomly on the page.

    #32715

    Nayem
    Moderator
    Post count: 6480

    Hello Ahmed,

    I am checking your issue. Please allow me some time to check and i will be back to you soon.

    Thank you ๐Ÿ™‚

    #32716

    Nayem
    Moderator
    Post count: 6480

    Hello Ahmed,

    Please provide your login details by using this form- http://wedevs.com/provide-login-details/. I will have a look what is going wrong.

    Thank you ๐Ÿ™‚

    #32726

    Ahmed
    Member
    Post count: 22
    This reply has been marked as private.
    #32728

    Wayne
    Member
    Post count: 22

    We are still waiting for any type of response = It has been more than 2
    weeks now and we have no resolution.

    Wayne Kendrick
    603-247-7220

    http://www.linkedin.com/in/wkendrick/

    #32730

    Nayem
    Moderator
    Post count: 6480

    Hello Ahmed,

    Please set your user membership level and expiration. Please navigate to admin dashboard-> User-> Edt user.
    You can follow this documentation- http://docs.wedevs.com/post-form-shows-please-purchase-pack/. Please try again and let me know.

    Thank you ๐Ÿ™‚

    #32731

    Nayem
    Moderator
    Post count: 6480

    Hello Wayne,

    Can you please provide your login details again?. Please help me to find out the actual problem. Provide your login details by using this form- http://wedevs.com/provide-login-details/. I will have a look what is going wrong.

    Thank you ๐Ÿ™‚

    #32732

    Ahmed
    Member
    Post count: 22

    Hey Nayem,

    Sorry, did you bother create a user and test it for yourself?

    Here is details of the bug:

    IN subscription.php there is a function that is used to check subscription called has_user_error.

    This function eventually uses get_user_pack method which only checks the WPUF packs not the PMP packs. It therefore returns back to add_post_shortcode which then renders the message rather then the form like it suppose to.

    Next time I expect that you will take the support requests seriously rather than take the approach you've taken.

    Please escalate this to Tareq before I will lodge a formal complaint to Paypal and WordPress.org

    #32736

    Ahmed
    Member
    Post count: 22

    This is where it goes wrong:

    ` function force_pack_permission( $perm, $id, $form_settings ) {
    $force_pack = wpuf_get_option( ‘force_pack', ‘wpuf_payment' );

    if ( $force_pack == ‘yes' && WPUF_Subscription::has_user_error( $form_settings ) ) {
    return ‘no';
    }

    return $perm;
    }'

    Also note that the pmp-wpuf plugin only hooks wpuf_sub_validity which is not used by the plugin to check in has_user_error.

    This means the wpuf plugin never checks subscription from the PMP plugin.

    This is a bug so please consider an appropriate response.

    #32759

    Sekander Badsha
    Member
    Post count: 2067

    Hello Ahmad,

    Both plugins subscription system share the same database table via the add-on. So the codes are not an issue. We are really sorry that we could not do every kind of testing for you; because we get tons of support requests everyday and we have communicate with all of them ASAP. So please forgive us for providing only instructions.

    As we can not test in detail, please read the links provided above and try once again. If you still find it difficult, then let me know here. I will check again for you ๐Ÿ™‚

    #32773

    Ahmed
    Member
    Post count: 22

    So it communicates via database? Where does it check the PMP tables for subcription? Where does it share that info and use it via the database. The answer is it doesnt. Did I not make that clear already?

    Did you not read my post? Have you tried it? Show me a working test environment? Prove to us it works with the versions and files supplied.

    I did try the link. I read it carefully and have tried this. It is not a solution to the problem.

    Your support team is attempting to decieve us and pretend they logged in to check.

    So what part of my response is not clear?

    #32802

    Ahmed
    Member
    Post count: 22

    Here are the screenshots of the settings:

    Settings 1

    Settings 2

    Settings 3

    Output 1

    Now quick summary:
    1. I've explained how “Post form shows ‘Purchase a Pack'” will always get displayed because the plugin code does not handle checking subscription anywhere except for the WPUF memberships, WPUF memberships do not exist when using the PMP extension or would not be in sync with PMP.
    2. I've explained how this is a bug.
    3. I've explained and now provided you screenshots of the settings you insist we check.
    4. You've attempted to deceive us by implying that you're going to login to check. When caught out, you claimed that you are not required to test because your so busy and that your plugins work, and clearly from the numerous reports on this forum (that you've ignored) it does not.
    5. You have not responded to the fact that numerous people on this forum are telling you your responses do not work.
    6. You have not responded to my request to see a working demo of the plugins.
    7. You are selling a plugin that does nothing and attempting at your best not to respond to queries as to why it does nothing.

    Now here is some more info for you. Not only does your plugin not handle the checking of subscriptions from the PMP plugin. You implied that it is a user setting under the users screen that is used to check active subscription.

    1. I already provided you details of how your plugin code ignores this, supposedly, shared data.
    2. You responded that you “are sorry” you could not test it because you're so busy that you cannot respond to the fact your plugin is sold to do something it does not do at all.
    3. I provided you with screenshots to prove it was configured correctly, in addition to the evidence that your code does nothing with it anyway.

    Heres some more info for you, even if the above configuration worked, the plugin code will still ignore the wpuf settings inside the PMP membership level. It will still ask the user for an additional cost to post.

    This indicates that not only is this a bug, but the WPUF plugin is not compatible with its extension and more so, it is actually not built to handle what the extension is trying to do. In other words, this is ample evidence that you're deliberately selling a fake plugin

    Now, what do you want to do? Do you want access AGAIN to the admin of the site to verify the screenshots above? Feel free, but I expect you provide me screenshots of were I've configured it wrongly.

    I still expect you to show me a working test site with the versions of the plugins you supplied.

    #32812

    Sekander Badsha
    Member
    Post count: 2067

    Hello Ahmed,

    I have your previous credentials. Can I login using that?
    Please make sure you have a complete backup of your site. I will login after your confirmation.

Viewing 15 posts - 16 through 30 (of 31 total)

The topic ‘Pmp add-ons’ is closed to new replies.