Home Forums Plugin Support WP User Frontend Pro Post status not following form settings

This topic is: not resolved

This topic contains 18 replies, has 4 voices, and was last updated by  Marcus 5 years, 5 months ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #1983

    titanweb
    Participant
    Post count: 15

    I've made a form where the post created should have the post status “Draft” but for some reason it's not following this setting and just defaults to “Published”.

    I can't find anywhere in the settings where there is a global setting for this so I can't really imagine why it's defaulting to published when I clearly have it set to draft.

    I'm creating a custom post type post “product” which is used by Woocommerce, sorted under a custom taxonomy. I'm creating the post from the front-end with some custom fields and an image upload. It is required that you need to be logged in and have purchased a subscription pack.

    Has anyone else run into this problem?

    #1985

    titanweb
    Participant
    Post count: 15

    However when I edit the post from the Dashboard, it changes the post status to draft correctly.

    #2065

    Tareq Hasan
    Keymaster
    Post count: 2831

    I am not sure whats going on, never faced any problem like this. Is your every form behaving like this?

    #2217

    titanweb
    Participant
    Post count: 15

    I'll test on a newly-made form and see if it occurs still.

    #2432

    titanweb
    Participant
    Post count: 15

    I've made a new form and the post still isn't getting saved as “draft”…it's still published on creation.

    I've only got two forms. The one for creating custom posts “product”, and for registering users. I have subscription packs enabled.

    Can I send you login details so you can have a look at my settings/plugins?

    #2436

    titanweb
    Participant
    Post count: 15

    Also I have two users. My admin account and a customer account. The post in the backend recognises the author as my admin, even though I've created it with my customer account :/

    #2441

    Mahi
    Member
    Post count: 1555

    Is your site online ? can you give us a test account ?

    reply with private settings .

    Thanks.

    #2500

    titanweb
    Participant
    Post count: 15
    This reply has been marked as private.
    #2513

    Mahi
    Member
    Post count: 1555

    I just test it and its working perfectly !

    After submit the product if you go to SHOP , you can't see your product(s) there. Cause, they haven't approved.

    Go to admin area -> Products-> post name

    on right hand side you will see your Items status like bellow –

     

    Thanks

    #2531

    titanweb
    Participant
    Post count: 15

    If only this was true 🙂

    That's just a custom field, it actually represents nothing other than emailing the client depending on the status.

    It's here that is the issue:

    The status, which is set in the form settings, should be Draft.

    When you edit this same product from the front-end, it does change the status. Only when you create does it not set it to Draft :/

    Also the only reason you are the author of the product is because you're an Administrator account. This makes me think that I might need to add more capabilities to the Customer role to enable them to be an author in the first place.

    So yeah, my initial problem still exists 🙁 Thank you for at least try though 🙂

    #2534

    Tareq Hasan
    Keymaster
    Post count: 2831

    The problem is in the plugin and it conflicts with the subscription setting. If you enable subscription and you have balance, it'll publish your post automatically.

    As a quick solve, I would suggest you to change `/class/subscription.php` line:251, where it says `'post_status' => ‘publish'` change it to `'post_status' => ‘draft'`. I'll try to fix this bug.

    #2652

    titanweb
    Participant
    Post count: 15

    Hi Tareq! Thanks for sorting that out for me 🙂 The status get's changed the “pending” now, instead of “draft” but I can work with that. Any status that removes posts visually from the front-end will do 🙂

    When I created a post with an Administrator account, the post status remained as published.
    When I created a post with a Customer/Subscriber account, the post status was changed to “Pending”.

    #3053

    titanweb
    Participant
    Post count: 15

    With your latest update (2.1.4) was this fixed or do I have to re-apply the hotfix to the subscription.php file?

    #3054

    Tareq Hasan
    Keymaster
    Post count: 2831

    Sorry, it's not been fixed yet.

    #4774

    titanweb
    Participant
    Post count: 15

    Hrm I've just tested this again but and it doesn't seem to be honouring my form setting to save the new post as ‘draft', ‘pending' or anything else for that matter (other than published).

    Is there somewhere else I can change code to make sure it stays as draft/pending?

    I'll provide links and log in details in a private reply.

    WordPress 3.5.1
    WPUF 2.1.5

Viewing 15 posts - 1 through 15 (of 19 total)

The topic ‘Post status not following form settings’ is closed to new replies.