This topic contains 18 reply and 6 voices, and was last updated by Sk 5 years, 3 months ago
Viewing 15 Posts - 1 through 15 (of 18 total)
Author Posts
June 13, 2014 at 4:07 am 21874
Sk I have a clean install of the theme and I'm noticing that the visibility isn't being set to "visible" when a new product is entered. I checked and on new-product.php is set with the following: update_post_meta( $product_id, '_visibility', 'visible' ); For some reason this doesn't seem to be working though?
June 13, 2014 at 8:03 pm 21890
Will Will

Alright so here’s an update. To see if this is was related to other plugins I had disabled all of them and tested. Same issue. So I started trying different things to troubleshoot it. I started a clean install of wordpress and installed the theme and woocommerce (only two plugins). I set everything up and now the seller’s dashboard page forwards to the woocommerce my-account page for some weird reason. I tried another install in case I messed something up – same issue. After poking around a while I deleted the dashboard page, added a new page called dash and set it to the dashboard template – now it works. Ok – weird but seems to be working. I post a product then from the seller’s dashboard and it works! Now I’m really confused. So many random things that seem to have no correlation with each other happening – especially on clean installs?

June 14, 2014 at 7:15 am 21909
Nizam Uddin Nizam Uddin

Hello Will
Have any problem at this moment? If yes please explain it with screenshot if possible. Thank you..

June 16, 2014 at 9:41 pm 22019
Will Will

I’ve started a clean site so it seems to be find right now. Can’t explain why it wasn’t working! Thanks.

June 16, 2014 at 11:14 pm 22021
Will Will

Well I spoke too soon! Here’s what’s happening.
1. I upload a new product
2. Product is published and uploaded (see status on the right)
3. Product shows up on homepage under latest products
4. Product isn’t showing up in “shop” section or under it’s category and
5. If I go and edit the product and click upload it will then show in the shop page and category results in

Currently the only plugins I have running are woocommerce and woocommerce stripe payment gateway. The weird part is it was working fine – but now it’s not. This was the same behaviour I had on the original site I was working on. I tried reuploading the theme via FTP just to ensure there wasn’t something changed as well. Any thoughts?

June 16, 2014 at 11:14 pm 22022
Will Will

Ugh… none of my screenshot links showed up.

June 17, 2014 at 12:09 pm 22045
Sekander Badsha Sekander Badsha

Hi Will,
In the Add New Product page, please check the ‘options’ tab and see if the visibility field is set to ‘catalog and search’. We guess somehow you changed that, that’s why your products are not showing up in the Shop or Category page.

June 17, 2014 at 9:31 pm 22069
Will Will

Unfortunately that isn’t the issue but good call. I can create a staging site with the same info and send you admin credentials if you’d like to try it. I also get weird behaviour when using firefox that I can’t explain. Basically the dashboard links end up just forwarding back to the “my-account” page from Woocommerce. The weird part is I can’t replicate it which most likely means it’s something I’m doing! grrr

June 19, 2014 at 11:31 am 22174
Sekander Badsha Sekander Badsha

Please send your site credentials as a private reply. We’d like to inspect what’s going wrong.

June 25, 2014 at 5:20 pm 22416
Olof Olof

Hello!
I have the same problem…. product being shown at “Latest products” but not in “Shop”. When visit the product at admin and update, the product is being shown.

When vendor “Add new product” and “add product” I get some error. Coming to 404site..
But when going back to Vendors, Product then new added product is displayed. But other problem.. vendor can’t edit the product.

Please help me out..

June 25, 2014 at 5:40 pm 22417
Olof Olof

Second problem solved.. I changed the productpermalinks to /store.

But still the problem with the new product not appearing at the “Shop” page..

Please help me out..

June 25, 2014 at 6:23 pm 22423
Olof Olof

UPDATE:
– First. When vendor add new product, works fine. (When see the “latest product” at site the product is being visible, at “shop” its hidden).
– Second. When vendor “update the product” the product suddenly get visible at the shop page to. (This is good because the vendor can edit the product settings before its gets visible at shop, bad thing is that the product is visible all the time at “latests products”..).

So something is not correct..

Maybe a solution is when “Add new product” is done the product get “pending” and when the vendor “update product” it gets visible at both “Latest product” and “Shop”. This WITHOUT the approval from admin. I want the vendors to create the product with no admin control. (Have tested in “PENDING REVIEW – Product status when a seller creates a product” and it works fine. When admin approve the product its gets visible correct at “Latest Products” and “Shop”)

Cheers / O

June 26, 2014 at 11:47 am 22469
Sekander Badsha Sekander Badsha

Hi Olof,
Though your problem is not clear; If you want your sellers to be able to publish a product right away without any admin approval, you may Change the “New Product Status” from Dokan > Settings > Selling Options.

Let me know if you have some more issues. 🙂

June 26, 2014 at 6:35 pm 22494
Olof Olof

The problem is that I want sellers products visible right away without any approval but sellers first publish the product and then set the other settings, like stock etc… The thing is that this newly added product is visible right away using the “Latest Products” feature BUT NOT in the store. Seller must click on “Update Product” AGAIN, then the product gets visible in store.
Another thing is, if seller just adds the product in first view it gets status “Online” but thats not true, not in store. Just under the latest products.
This is a BIG problem because what happens when a Seller is creating a new product and don’t click update product at second view? He thinks the product is online and may even double-check the website frontpage and see his/her product under the latest product but again thats not true, product is hidden at store..

Please help me out with this, this is a BIG problem for all customers and sellers.

June 29, 2014 at 12:32 pm 22575
Sekander Badsha Sekander Badsha

Hi Olof,
After creating a product, you’re being redirected to enter the other options. So you must enter them. Process of adding a product can not be completed without adding other options like – stock and shipping options. So there’s no space for confusion.

And the issue you mentioned about latest product and store, I’ve notified the Dev Team. They’ll have a look at that.

June 29, 2014 at 2:08 pm 22580
Olof Olof

Ok thank you, please prio this problem. Its very confusing for store owners.

Viewing 15 Posts - 1 through 15 (of 18 total)