Home Forums Theme Support Dokan Product visibility issues

This topic is: resolved

This topic contains 18 replies, has 6 voices, and was last updated by  Sk 4 years, 11 months ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #21874

    Will
    Member
    Post count: 28

    I have a clean install of the theme and I'm noticing that the visibility isn't being set to “visible” when a new product is entered. I checked and on new-product.php is set with the following:
    update_post_meta( $product_id, '_visibility', 'visible' );
    For some reason this doesn't seem to be working though?

    #21890

    Will
    Member
    Post count: 28

    Alright so here's an update. To see if this is was related to other plugins I had disabled all of them and tested. Same issue. So I started trying different things to troubleshoot it. I started a clean install of wordpress and installed the theme and woocommerce (only two plugins). I set everything up and now the seller's dashboard page forwards to the woocommerce my-account page for some weird reason. I tried another install in case I messed something up – same issue. After poking around a while I deleted the dashboard page, added a new page called dash and set it to the dashboard template – now it works. Ok – weird but seems to be working. I post a product then from the seller's dashboard and it works! Now I'm really confused. So many random things that seem to have no correlation with each other happening – especially on clean installs?

    #21909

    Nizam Uddin
    Keymaster
    Post count: 670

    Hello Will
    Have any problem at this moment? If yes please explain it with screenshot if possible. Thank you..

    #22019

    Will
    Member
    Post count: 28

    I've started a clean site so it seems to be find right now. Can't explain why it wasn't working! Thanks.

    #22021

    Will
    Member
    Post count: 28

    Well I spoke too soon! Here's what's happening.
    1. I upload a new product
    2. Product is published and uploaded (see status on the right)
    3. Product shows up on homepage under latest products
    4. Product isn't showing up in “shop” section or under it's category and
    5. If I go and edit the product and click upload it will then show in the shop page and category results in

    Currently the only plugins I have running are woocommerce and woocommerce stripe payment gateway. The weird part is it was working fine – but now it's not. This was the same behaviour I had on the original site I was working on. I tried reuploading the theme via FTP just to ensure there wasn't something changed as well. Any thoughts?

    #22022

    Will
    Member
    Post count: 28

    Ugh… none of my screenshot links showed up.

    #22045

    Sekander Badsha
    Member
    Post count: 2067

    Hi Will,
    In the Add New Product page, please check the ‘options' tab and see if the visibility field is set to ‘catalog and search'. We guess somehow you changed that, that's why your products are not showing up in the Shop or Category page.

    #22069

    Will
    Member
    Post count: 28

    Unfortunately that isn't the issue but good call. I can create a staging site with the same info and send you admin credentials if you'd like to try it. I also get weird behaviour when using firefox that I can't explain. Basically the dashboard links end up just forwarding back to the “my-account” page from Woocommerce. The weird part is I can't replicate it which most likely means it's something I'm doing! grrr

    #22174

    Sekander Badsha
    Member
    Post count: 2067

    Please send your site credentials as a private reply. We'd like to inspect what's going wrong.

    #22416

    Olof
    Member
    Post count: 49

    Hello!
    I have the same problem…. product being shown at “Latest products” but not in “Shop”. When visit the product at admin and update, the product is being shown.

    When vendor “Add new product” and “add product” I get some error. Coming to 404site..
    But when going back to Vendors, Product then new added product is displayed. But other problem.. vendor can't edit the product.

    Please help me out..

    #22417

    Olof
    Member
    Post count: 49

    Second problem solved.. I changed the productpermalinks to /store.

    But still the problem with the new product not appearing at the “Shop” page..

    Please help me out..

    #22423

    Olof
    Member
    Post count: 49

    UPDATE:
    – First. When vendor add new product, works fine. (When see the “latest product” at site the product is being visible, at “shop” its hidden).
    – Second. When vendor “update the product” the product suddenly get visible at the shop page to. (This is good because the vendor can edit the product settings before its gets visible at shop, bad thing is that the product is visible all the time at “latests products”..).

    So something is not correct..

    Maybe a solution is when “Add new product” is done the product get “pending” and when the vendor “update product” it gets visible at both “Latest product” and “Shop”. This WITHOUT the approval from admin. I want the vendors to create the product with no admin control. (Have tested in “PENDING REVIEW – Product status when a seller creates a product” and it works fine. When admin approve the product its gets visible correct at “Latest Products” and “Shop”)

    Cheers / O

    #22469

    Sekander Badsha
    Member
    Post count: 2067

    Hi Olof,
    Though your problem is not clear; If you want your sellers to be able to publish a product right away without any admin approval, you may Change the “New Product Status” from Dokan > Settings > Selling Options.

    Let me know if you have some more issues. ๐Ÿ™‚

    #22494

    Olof
    Member
    Post count: 49

    The problem is that I want sellers products visible right away without any approval but sellers first publish the product and then set the other settings, like stock etc… The thing is that this newly added product is visible right away using the “Latest Products” feature BUT NOT in the store. Seller must click on “Update Product” AGAIN, then the product gets visible in store.
    Another thing is, if seller just adds the product in first view it gets status “Online” but thats not true, not in store. Just under the latest products.
    This is a BIG problem because what happens when a Seller is creating a new product and don't click update product at second view? He thinks the product is online and may even double-check the website frontpage and see his/her product under the latest product but again thats not true, product is hidden at store..

    Please help me out with this, this is a BIG problem for all customers and sellers.

    #22575

    Sekander Badsha
    Member
    Post count: 2067

    Hi Olof,
    After creating a product, you're being redirected to enter the other options. So you must enter them. Process of adding a product can not be completed without adding other options like – stock and shipping options. So there's no space for confusion.

    And the issue you mentioned about latest product and store, I've notified the Dev Team. They'll have a look at that.

Viewing 15 posts - 1 through 15 (of 19 total)

The topic ‘Product visibility issues’ is closed to new replies.