Home Forums Plugin Support WP User Frontend Pro Registration form doesn't display at all in registration tunnel

This topic is: resolved

This topic contains 15 replies, has 3 voices, and was last updated by  towhid 3 years, 12 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #54483

    Roger
    Member
    Post count: 22

    MY CONFIG : wp-user-frontend-pro v2.3.5 and Paid Memberships Pro v 1.8.4.2 – WP 4.2.2

    What I need is to display my Registration Form (made with WPUF for first visit or account creation ) to get personal subscriber's details before displaying him the “subscription pack” selectin page and sending him to Paypal Payment page.
    So first, I created a registration form and integrated its shortcode on a specific register page ([wpuf_profile type=”registration” id=”1269″]) to be able to display it, then I created a subscription pack with WPUF.

    Issue 1 :

    When I'm not logged in, if I click REGISTER, the Registration form page I created doesn't display and I cannot achieve my registration. The seen page has 2 buttons “login” and “register” and the “register” button doesn't work !

    When I'm logged in as admin or contributor account, I cannot access Registration form page too (and don't access to the login and register 2 buttons pages). But the subscription pack page is displayed instead before displaying paypal gateway.

    Issue 2 :
    In both cases, I see the dashboard but I cannot edit my posts thought it

    Thank you for your prompt help

    CGC

    #54485

    Roger
    Member
    Post count: 22

    here is my site : http://alliancej.cluster010.ovh.net/

    dashboard : http://alliancej.cluster010.ovh.net/mon-espace-contributeur/
    post creation : http://alliancej.cluster010.ovh.net/nouvelle-contribution/
    profile : http://alliancej.cluster010.ovh.net/profil-contributeur/
    level : http://alliancej.cluster010.ovh.net/membership-account/mon-abonnement/
    register : http://alliancej.cluster010.ovh.net/devenir-membre/
    registration form : http://alliancej.cluster010.ovh.net/formulaire-adhesion-contributeur/

    The purpose here is to enable visitors to become contributors (after selecting their subscription pack) so that they could post contents in my website. The aim is not to enable posts complete reading.

    TIA

    Roger

    #54598

    towhid
    Participant
    Post count: 4505

    Hello Roger,

    I have tried to reproduce this issue but failed. It could be a has a chance of theme or plugin conflicts. You can disable all your plugins except User Frontend and switch to a default theme of WordPress like- Twenty Twelve, Twenty Thirteen, Twenty Fourteen and let me know the results.

    Thanks

    #54650

    Roger
    Member
    Post count: 22

    I already did but nothing changed !
    the first thing is : why when I put my registration form shortcode in any page, the form does not appear !!!
    that's crazy !!
    do you have any clue ?
    Roger

    #54727

    towhid
    Participant
    Post count: 4505

    Please provide your login details by using this form: http://wedevs.com/provide-login-details/. I will have a look what is going wrong.

    Thank you 🙂

    #54803

    Roger
    Member
    Post count: 22

    OK thank you ! : ))

    1/ If I use the login/pw I create specially for you (sent by provide-login-details), I get access directly to (http://alliancej.cluster010.ovh.net/nouvelle-contribution/ ) and when I click on “register link” (in yellow alert), I go directly to the subscription pack page (http://alliancej.cluster010.ovh.net/pack-adherent-contributeur/) and I don't see any registration form ! is it normal even if I login with an admin account?

    2/ As a new visitor who never logged in before, I get access directly to home's sidebar (Mon espace Contributor widget) or specific page (http://alliancej.cluster010.ovh.net/nouvelle-contribution/) and I click on registration link (Première Inscription in widget or “register link” in yellow alert) , I get to a page with 2 buttons LOGIN and REGISTER (I duplicated them in blue for styling reason but I kept to perform testing the two grey initial ones). If I click on REGISTER (right one), no registration form appears ! If I click on LOGIN one (left one), I get to back-office login access instead of frontend login access !!

    That's the main problem !!!

    What I need in fact (in both cases) is to display the registration form to enable registration to a new visitor and enable a connected member to see its details (or profile)

    You will see all the member pages made with wupf accessible through main navigation bar (MON ESPACE)

    Thank you for your appreciated help !! :))

    Roger

    #54895

    towhid
    Participant
    Post count: 4505

    Hello Roger,

    It will act how you setup.

    You have enabled Subscription at registration = Registration time redirect to the subscription page. So that registration page redirects you to the subscrioption page. If you disable this setting it will not redirect there.

    I am not sure how do you create this two button in this link. Please check that you have properly hyperlinked those two buttons. If those two buttons are populated from the template then it needs to hire a developer to fix this.

    Thanks

    #55730

    Roger
    Member
    Post count: 22

    Hi Towhid,

    Thanks for your answer but it didn't solve the issues so far.

    1/ As you say, if I disable the setting “Registration page redirects you to the subscription page”, it surely redirects to registration form instead of subscription page but the form itself doesn't appear anyway within Registration page ! That's the point !
    Whatever setup I do, even if I'm logged in or not, the result is the same : I don’t see ANY registration form !
    So for me, this is NOT a link/redirection issue but a form display or shortcode recognition issue !!

    2/ The buttons I created (blue) have the same hyperlink code than the 2 initial ones (grey) made by wupf. So forget the blue and use only the initial grey ones.
    The link of REGISTER button redirects to : http://alliancej.cluster010.ovh.net/wp-login.php?action=register
    This hyperlink seem to be correct but the registration form itself doesn't appear above the button (we see three suspension points instead, like if it didn't recognize the shortcode inside i.e. [wpuf_profile type=”registration” id=”1269″]

    The link of LOGIN button seem to be right too : http://alliancej.cluster010.ovh.net/wp-login.php
    If I'm not logged in (1st visit), I'm redirected to the same registration form page but the form doesn't appear too ! (same issue)
    and if I click on this LOGIN button, I'm redirect to Back-End login page instead of Front-End login page ! that's the second point / issue !!

    So for me, this second issue is how to force the redirection to Front-End login instead Back-End login page when the visitor is not logged in yet !

    Please Thank you for checking that and advise

    TIA : )

    Roger

    #56147

    Roger
    Member
    Post count: 22

    Hello Townhid
    I ‘m still waiting for your answer concerning the two issues mentionned in my last post sent 3 days ago. I urgently need to solve this registration form display (or shortcode recognition) issue ASAP !
    It really seems to be a bug because whatever settings I use, I never succeed in displaying my registration form
    Thank you for your earliest answer : )
    Roger

    #56204

    Nayem
    Moderator
    Post count: 6480
    This reply has been marked as private.
    #56259

    Roger
    Member
    Post count: 22

    Registration is not allowed

    Hello

    Could you be kind enough to help me resolving a small issue during Towhid holiday ! You can imagine I have to deliver my dev to my customer even if your support is closed.

    I begin from scratch the instal and setup of wufp and now I am getting this simple error message when I go to my registration page : “User registration is currently not allowed.”
    It's a well known issue from your side because an old thread #1762 (dated 2 years ago) gave the answer : Go to admin area -> Settings -> General -> Membership -> make sure you select to Anyone can register.

    But the thing is that in the last version of wufp (v.2.3.5), this setting doesn't exist anymore !!

    Could you check please and help me ?

    TIA

    Roger

    #56296

    Nayem
    Moderator
    Post count: 6480

    Hello Roger,

    Our developers are also in vacation. Actually it is EID vacation here. @towhid forwarded this issue to developer team but for this vacation it is not possible to check your issue. I am really sorry for the inconvenience.

    Did you set your registration page for the contributor and subscriber role? Please provide a screenshot of the registration settings of WP user frontend pro.

    Thanks.

    #56639

    Roger
    Member
    Post count: 22

    OK thanks Nayem

    I reinstalled wpuf, set it up from scratch without using Paid Memberships Pro and I finally succeeded in fixing the above pending issues.

    With my new settings, registration process is working well now ; )
    My registration process is now : subscription pack page -> registration form -> Paypal payment page because of the following settings :

    1/ content form / Post settings : redirect to newly created post
    2/ content form / edit settings : redirect to same page
    3/ registration form : redirect to subscription page
    4/ wpuf settings / General options : edit page implemented
    5/ wpuf settings / Connexion-inscription : register & connexion pages implemented
    6/ wpuf settings / payment : force pack purchase + subscription page implemented + Registration time redirect to subscription page checked

    But now, two others issues appeared !! :

    1/ EDITION OF MEMBER PROFILE incompatible with my settings
    I need to edit in a specific page the “member profile” (after member's registration and payment completed).
    But the issue is : if I want to go to member profile page (http://alliancej.cluster010.ovh.net/mon-profil-contributeur/), I'm automatically redirected to register page and If I changed any settings, I broke my registration process !

    So Please, what's wrong with this and how could I have my profile page well displayed without affecting my registration process ?

    2/ in backend USER menu, no WPUF Subscription appears in drop down menu !
    Is it normal ? If I click on “assign a package”, there is no selection item in drop down menu !?

    Thank you for your prompt answer

    regards

    Roger

    #56704

    Nayem
    Moderator
    Post count: 6480

    Hello,

    Please provide screenshot for your both issue. It will help me to find out the solution.

    Thanks.

    #56806

    Roger
    Member
    Post count: 22

    OK
    How could I send you screenshots ?
    Roger

Viewing 15 posts - 1 through 15 (of 16 total)

The topic ‘Registration form doesn't display at all in registration tunnel’ is closed to new replies.