Home Forums Theme Support Dokan seller upload image error

This topic is: resolved

This topic contains 28 replies, has 3 voices, and was last updated by  Nayem 4 years ago.

Viewing 15 posts - 1 through 15 (of 29 total)
  • Author
    Posts
  • #44301

    Brian
    Member
    Post count: 14

    I discovered a bug in Dokan… if a seller tries to login here /my-account/ (front-facing site) then access seller dashboard > products > upload image … it gives an upload error.

    However, when the same seller logs in through the normal WP Login … e.g. mysite.com/wp-login.php
    then uploads an image, it works fine.

    Dokan Team, please fix asap.

    Thanks!!!

    #44330

    towhid
    Participant
    Post count: 4505

    Hello Brian,

    I have reproduced this issue but did not get any error while uploading a new image. If the issue still persists then check for your theme or plugin conflicts. You can disable all your plugins except Dokan and switch to a default theme of WordPress like – Twenty Twelve, Twenty Thirteen, Twenty Fourteen and let me know the results.

    Thanks.

    #44379

    Nayem
    Moderator
    Post count: 6480

    Please provide a screenshot here. It will help me to find out the solution.

    Thanks.

    #44411

    Brian
    Member
    Post count: 14

    Steps: (Starting with no one logged in to the site)

    1) Seller goes to my account login:

    https://www.dropbox.com/s/9blg23nxxe5ct7g/sc1.png?dl=0

    2) Logs in from front of site, then goes to Seller Dashboard > Products > Product (Upload a Product Cover image)

    https://www.dropbox.com/s/wdwu0gyrtwq81vc/sc4.png?dl=0

    3) Uploader tries to upload image, but it won't complete before an error is thrown

    https://www.dropbox.com/s/9eop5q5ji7734j8/sc5.png?dl=0

    (ALSO noticed that it logs the seller out of the site every few minutes. It appears WP does not like users logging in this way! This seems to happen immediately after attempting to upload the image, clicking anywhere takes the seller back to the My Account login screen)

    Next, log out of site. Then Seller logs in from mysite.com/wp-login.php (dokan redirects to front facing site)

    Then repeat the above steps, and it successfully uploads images, no problem. I tried disabling all other plugins, also I am using the Dokan Theme. So this appears to be a Dokan issue.

    Thanks!!!

    #44412

    Brian
    Member
    Post count: 14

    I think I found the culprit… but this is still a problem with Dokan… I disabled woocommerce's option to “Force SSL at checkout”… when this option in Woocommerce > Settings > Checkout is disabled, sellers are able to upload images.

    My site's Dokan still needs to work if SSL on certain pages is enabled. Please advise… thanks!

    #44413

    Brian
    Member
    Post count: 14

    Paypal Pro requires Force SSL at checkout. Otherwise, cc transactions are not secure….

    #44445

    Nayem
    Moderator
    Post count: 6480

    Hello Brian,

    In my side i have enabled Force SSL at checkout. But i can easily upload product image. In dokan we have just check the file format and the size when upload a image. So i think there should be another issue. Can you please check your server file permission? You can set your file permission as 644 and check for the issue.

    Thanks.

    #44520

    Brian
    Member
    Post count: 14

    Hi Nayem,

    As indicated above, A seller is able to upload successfully (meaning it is not a file permission problem) both when the SSL is disabled, or (with SSL ENABLED) when the seller logs in through the WP Admin login page (/wp-login.php).

    You have to make sure you are testing only with the seller privilege level. Let's assume after you have toggled the SSL option ON, then all users log out of the WP Admin Dashboard. Next, the seller logs in through the front facing site (/my-account/ page), THEN, and only then, uploading from the front-end doesn't work.

    Thanks!

    #44562

    Nayem
    Moderator
    Post count: 6480

    Hello Brian,

    I have checked as you have mentioned. But did not get any error.

    Please provide your login details by using this form: http://wedevs.com/provide-login-details/. I will have a look what is going wrong.

    Thank you.

    #44684

    Brian
    Member
    Post count: 14

    Ok, done.

    #44780

    Nayem
    Moderator
    Post count: 6480

    I did not get your details yet. Please try again to send your details.

    #44849

    Brian
    Member
    Post count: 14
    This reply has been marked as private.
    #44908

    Brian
    Member
    Post count: 14

    Any updates? Client is waiting for a resolution.

    #44914

    Nayem
    Moderator
    Post count: 6480

    Hello Brian,

    I am really sorry for the inconvenience. We were in weekend. I am checking your site now. Please allow me some time.

    Thanks.

    #44973

    Nayem
    Moderator
    Post count: 6480

    I have to discuss with our developer team. They are now in weekended. I will be back to you tomorrow with proper solution.

    Thanks.

Viewing 15 posts - 1 through 15 (of 29 total)

The topic ‘seller upload image error’ is closed to new replies.