Home Forums Plugin Support WP User Frontend Pro Woocommerce Custom Taxonomies not saving when published as draft

This topic is: not resolved

This topic contains 2 replies, has 2 voices, and was last updated by  towhid 4 years ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #51623

    Soft
    Member
    Post count: 1

    Hi,

    We are using WPUF-Pro to hook into woocommerce and post products from the front end.

    After spending ages getting it all working. We discovered the when posting a product for the first time (not an edit to an existing product) saving it as a draft wont save the data for the woocommerce Custom Taxonomies.

    All other fields save fine. again this is only when saving as a draft for the original time. if its published right away it works fine. same with editing already published products and setting them to draft mode also works.

    Clueless as to what todo now.

    Thanks

    #51628

    Soft
    Member
    Post count: 1

    Fixed this myself,

    Turns out theres a bug in the plugin. the code that runs when a draft post is saved is not the same code that runs when a live post is saved. and the woo commerce sections of both functions are out of sync. the draft section is missing most of the code the live post has. a quick copy and paste and everything's working.

    WeDev's do you take patch's/pull requests?

    #51655

    towhid
    Participant
    Post count: 4505

    Hello,

    Can you please post here the missing code of draft post for help track the problem and its solution.

    Thanks

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Woocommerce Custom Taxonomies not saving when published as draft’ is closed to new replies.