This topic contains 15 reply and 4 voices, and was last updated by Alex 5 years, 11 months ago
Viewing 15 Posts - 1 through 15 (of 15 total)
Author Posts
September 5, 2013 at 4:09 pm 7827
Alex Hi guys, Since the weekend, I have been having massive problems with this error message for any users other than Admin accessing the site. This means, nobody can post! From what I recall, the only thing that I changed was the Permalinks settings from 'Day and Name' to 'Post name'. I have tried swapping that back but it has not worked. I have all users other than the Admin set up as Contributors. This has not changed. I have Admin Access Area set to Admins only because I do not want users to access the backend, they can only post on the front end. This was set like this before hand and was working before the weekend. I also use Theme My Login and have the redirection path set to http://mysite.com/rescues/%user_login%/my-pets - this was working before the weekend and has not changed. I have also tested all other User Roles links and tested when TML is set to Default after logging in but to no avail. There are no additional plugins installed to cause this issue - the only thing that has changed on the site were the permalinks from what I recall. I hope you can help Cheers Damien
September 5, 2013 at 4:57 pm 7831
Mahi Mahi

Hello Damien,

With WPUF, you dont have to worry about your users role, any one can post from front-end.
And, from WPUF plugin settings you can setup back-end access – Admin only.

Not sure whats going on with your site, possibly somehow your admin’s role been changed. If you can’t do anything then change it from phpMyadmin

September 5, 2013 at 5:06 pm 7832
hatchmedia hatchmedia

Hi Mahi,

The problem though is that no users other than the Admin are able to login to the site to post onto the frontend.

This has been working for me for the last 7 months using WPUF and WPUF Pro when it was released, but since the weekend, the users are unable to login.

So, to reiterate, my Admin is fine, no problems, its all other users. Only the admin is allowed access the backend so I do have backend access set to admin only, but this has been the same for the last 7 months when everything was working.

When the other users try to login to post on the front end, they receive the message – “Access Denied, Your site administrator has blocked your access to the WordPress back-office” and that has only been since the weekend because the last user post was posted on 31st of August.

Cheers

Damien

September 5, 2013 at 10:19 pm 7836
hatchmedia hatchmedia

Hey guys

Is anyone able to help with this?

Cheers

Damien

September 6, 2013 at 4:03 am 7845
Mahi Mahi

Hello Damien,

Can you share your site login details with us? Please reply as private.

September 6, 2013 at 4:55 am 7848
hatchmedia hatchmedia This reply has been marked as private.
September 6, 2013 at 7:27 pm 7865
hatchmedia hatchmedia

Hi Mahi/Tareq

Have either of you had a chance to look into this? My site has effectively been not working for the last week and I am very eager to get it fixed.

When I disable WPUFPro the other users are able to login, when I reenable it, i get the same issue again.

Thanks

Damien

September 7, 2013 at 2:26 pm 7886
hatchmedia hatchmedia

Hi Mahi,

Have you had a chance to look at this yet? I’m sorry to ask again, but I really need some help with this.

Thanks

Damien

September 8, 2013 at 1:54 pm 7921
Tareq Hasan Tareq Hasan

I just logged in with paws account and made post. It worked just fine. I think everything is working fine?

September 8, 2013 at 2:58 pm 7925
hatchmedia hatchmedia

Hi Tareq!

Thank you for testing this! I appreciate it.

The only problem is that when I try to log back in with the paws account, I encounter the same message about not having access to the back-office.

What is also strange is that I have noticed another user was able to post yesterday.

Could this be an IP address related issue? I will be trying it somewhere else today as a test, but thats the only explanation I can come up with for now?

Damien

September 8, 2013 at 3:26 pm 7927
Tareq Hasan Tareq Hasan

No, this is not an IP address issue. I think what might be is, when the user is loggin in, it’s redirecting the user to wp-admin and you are seeing that error and which is normal. Navigating to the site homepage should be fine. As you are using WPUF’s user blocking option, this is working as it should.

You can use “Peter’s Login Redirect” plugin to redirect a user to homepage after loggin in.

September 8, 2013 at 6:07 pm 7931
hatchmedia hatchmedia

Hi Tareq,

Whilst this does make sense, I have a few of concerns.

– This was all working fine up until last week, nothing changed from what I can recall with the exception of the permalinks.
– I currently use Theme My Login. That already has a redirection module and none of the user roles are set to go to the Admin screen, all to the WPUF Dashboard area.
– Logging in as the example user works for you, but not for me, which would suggest that they are being redirected to the correct location for you and not me?

The reason for me needing to get in as one of the users is I do actually need to set up their dashboard areas better than they currently are, but cant really get the proper user experience if I cannot log in as them.

I hope you can address some of my follow up concerns.

Thanks again as ever!

Damien

September 12, 2013 at 3:17 pm 8065
hatchmedia hatchmedia

Hey Tareq,

Just a quick update – Peters Login Redirect plugin did work for me.

I am still a bit baffled as to why I needed to install this though as the logins had been working fine without it up until this issue started happening.

Working now anyway! Thanks

Damien

December 12, 2013 at 4:20 am 13642
Alex Alex

hi I have same issue did you get to fix it? if so how…? please advice since Im un able to use it

December 12, 2013 at 4:07 pm 13655
hatchmedia hatchmedia

Hey Alex,

I installed Peters Login Redirect plugin and it resolved the issue.

As I mentioned before, I’m not sure why I needed to as the site had been working perfectly before hand, but I have not had any issues with it since installing the plugin.

I hope this helps

Damien

December 12, 2013 at 10:16 pm 13664
Alex Alex

Damien, thanks for the suggestion…. I will give it a try but the truth is that the plugging should handle this as is a function on the plugging, what I did in the mean time was deleting the code in the plugging that control the access to back end, but I guess your solution is better…

Viewing 15 Posts - 1 through 15 (of 15 total)