Dokan Released as a Plugin – Here’s Everything You Need to Know

As we have announced earlier, the time to release Dokan theme as a standalone plugin has arrived and we are super excited to release all the functionality of Dokan theme inside a single plugin! This makes it super easier for you to install Dokan and get started with its multi-vendor e-commerce support even in your existing WooCommerce theme.

dokan plugin
Seller Dashboard on Twenty Twelve theme running on Dokan plugin.

In today's post, we'd like to take you through some of the things that you need to know about today's Dokan release as a plugin.

All Functionality Moved to Dokan Plugin

Every bit of functionality that you love and enjoy has been moved to the plugin. So all you need now to have all the features of Dokan on your e-commerce site is just the plugin. Install WooCommerce (the plugin Dokan is based on) and Dokan plugins and you're ready to go!

Use Any WooCommerce Theme You Want

One of the frustrating things for many of you was that you had to use the Dokan theme's design on your Dokan-powered site. Although Dokan is highly customizable in terms of design, many of you would rather use another WooCommerce-enabled theme available elsewhere on the web.

With Dokan plugin, that is now possible! Since all of Dokan's functionality has been moved to a plugin, you are no longer tied to a single theme. You can choose from hundreds of WooCommerce-supported themes out there and not worry whether Dokan will work on that or not.

Dokan Theme Bundled Free with the Plugin

If you'd rather use the existing Dokan theme, don't worry; Dokan theme comes as a free theme bundled with the plugin. That means any time you purchase the plugin, the theme will be bundled for free! And if you're an existing customer, you will be able to download both the plugin and the new theme from your weDevs account when the plugin is released. You will have to activate the plugin and then you may activate the Dokan theme to keep the current design on your site.

WooCommerce 2.2-Ready

WooCommerce recently released an update to its plugin, version 2.2 (as of this writing, the latest version is 2.2.4). Dokan plugin is compatible with WooCommerce 2.2+. So you must update your WooCommerce plugin to version 2.2+ (preferably 2.2.4) in order to use Dokan plugin on your site.

Click here to see a number of new features that have been introduced to WooCommerce 2.2.

Upgrade is Mandatory

This is important; because we are deprecating the theme, meaning the existing Dokan theme will no longer receive any update. So if you're using Dokan on your site, you have to upgrade to the newly released Dokan plugin. But whether or not you want to use the Dokan theme that comes bundled with the plugin is entirely up to you. As said above, you may use another WooCommerce-enabled theme, or you may avoid purchasing another theme and continue using the Dokan theme.

Regardless of what theme you use, you have to upgrade to Dokan plugin to continue receiving updates.

Free for Existing Customers

Just as new Dokan plugin customers will receive the Dokan theme, existing Dokan theme customers will receive Dokan plugin and the new Dokan theme v2.0 as well. Just head over to your weDevs Account page to download Dokan plugin and theme.

How to Upgrade to Dokan Plugin

Our documentation has a detailed tutorial on how to upgrade to Dokan plugin from existing Dokan theme. Check out the upgrade tutorial here.

So what are you waiting for? Upgrade to Dokan plugin and enjoy the freedom of choosing any theme you want! You can learn more about Dokan plugin in our previous post here. If you have a question, do not hesitate to ask in the support forums.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.