Home Forums Plugin Support WP User Frontend Pro A few issues – Edit page, author info and email required

This topic is: resolved

This topic contains 8 replies, has 2 voices, and was last updated by  Michael 5 years, 6 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #7086

    Michael
    Participant
    Post count: 27

    Hi,

    I have a found a few issues while setting up my User Frontend Pro.

    1. Edit page – I have gone through the documentation for this process, placing [wpuf_edit] on it's own page. When going to that page however, I get the following error –

    I don't know how to edit this post, I don't have the form ID

    Should the user also have a link on their user dashboard for an option to edit? I see the option to delete, but not to edit.

    2. Author Info – I am having one technical issue and one feature issue. In the registration form I set up, I have a place for an author bio. I see that this bio can be viewed on the front end. The technical issue I am having is if too much information is placed in the form, everything is jumbled up. I will attach a screenshot for an example:

    Author Info

    The feature issue relates to editing the author info. I might have missed a setting somewhere but is it possible to allow the author to edit this information on their dashboard?

    3. Require email – When a user registers, is it possible to require an email check before they are approved? For example, “check your email for a link to confirm your account.”

    Thank you!

    Michael

    #7088

    Michael
    Participant
    Post count: 27
    This reply has been marked as private.
    #7095

    Michael
    Participant
    Post count: 27

    Hi,

    I found a solution for #1 in the documentation but it's not fixing my problem. The form used to create a post from the front end is assigned to both the post and the page with [wpuf_edit]. I still get the error and I am unable to edit the posts.

    Here were my steps to try to resolve #1.

    1. Ensure that the correct form was selected on page with [wpuf_edit].
    2. Ensure that the correct form was selected on the post.
    3. Ensure that page with [wpuf_edit] was selected in the general settings.
    4. Dashboard settings are set to “Yes” for “Users can edit posts.” (Though I should note again that there is not option in the dashboard for a user to edit their post. I must create a separate menu item for this.)

    I believe I have all bases covered for #1.

    I still cannot find a solution for 2 or 3.

    #7099

    Mahi
    Member
    Post count: 1555

    Hello @michael

    1. You got the wrong idea. You have to create an edit page and select this page from backend edit settings option, so users can edit their posts. You DO NOT have to show this page at front-end or go directly this page to edit posts

    2. I think, your theme was overwriting and, when you created registration form there are two shorcodes there. One for registration another one for profile edit.

    So, you have to create 2 pages and setup accordingly. I created 2 pages check that out.

    3. Sorry, its not build-in to WPUF. You have to use 3rd party plugin.
    I will recommend you to use – http://wordpress.org/plugins/register-plus-redux/ for registration . But, be careful it offers few additional features which may conflict with WPUF. So, use only what you required.

    4. Edit button visible at new dashboard page i created.

    #7100

    Michael
    Participant
    Post count: 27

    Mahi,

    Thank you so very much. Steller customer support as always.

    My next step is to write a testimonial for you.

    Michael

    #7102

    Michael
    Participant
    Post count: 27

    Upon one final check, everything looks wonderful. The only remaining issue is how the author info is displayed. It's all scrunched up and the background looks bad. Any idea why this would be?

    Below is that image again for your reveiw.

    http://spoondish.com/wp-content/uploads/2013/08/Author-info.png

    #7103

    Michael
    Participant
    Post count: 27
    This reply has been marked as private.
    #7104

    Mahi
    Member
    Post count: 1555

    Its a css issue.

    Go to – wp-content/plugins/wp-user-frontend-pro/css/frontend-forms.css

    Find:
    .wpuf-author-inside

    just change – height:90px; to height:100%;

    Thanks,

    #7105

    Michael
    Participant
    Post count: 27

    Perfect!!

    Thank you!

    Michael

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘A few issues – Edit page, author info and email required’ is closed to new replies.