Home Forums Theme Support Dokan An error occurred in the upload. Please try again later.

This topic is: resolved

This topic contains 12 replies, has 2 voices, and was last updated by  towhid 3 years, 11 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #52090

    Fearg
    Member
    Post count: 80

    Hi Guys,

    I get the error “An error occurred in the upload. Please try again later.” anytime I try to upload an image from a non admin vendor account. The non-admin user also gets logged out immediately after trying to upload.

    I looked at other threads in the forum where users had similar issue and I have tried changing the upload file permission settings to 744 / 755 but this does not fix the issue. Is there anything else that I can try? This was working fine up until a few days ago.

    Thanks

    #52092

    towhid
    Participant
    Post count: 4505

    Hello Fearg,

    I have tried to reproduce this issue but failed. Make sure you had properly configured Dokan settings. If the issue still persists then check for your theme or plugin conflicts. You can disable all your plugins except Dokan and switch to a default theme of WordPress like – Twenty Twelve, Twenty Thirteen, Twenty Fourteen and let me know the results.

    Thanks

    #52122

    Fearg
    Member
    Post count: 80

    Hi towhid,

    My issue is exactly the same as the one discussed in this thread

    https://wedevs.com/support/topic/seller-upload-image-error/page/2/

    I can upload images if I turn off the force secure checkout (SSL) and it also works if the vendor logs in through the /wp-login.php page rather than they my account page.

    Its not entirely clear to me how that issue was resolved though. Do I just need to install this plugin https://wordpress.org/plugins/wordpress-https/ or did you guys do more from the backend?

    #52139

    towhid
    Participant
    Post count: 4505

    Hello Fearg,

    Please read this documentation through this link – http://docs.wedevs.com/ssl-error/. It will help you to get a solution.

    If you need any further assistance please contact me. I am here to help you.

    Thanks

    #52155

    Fearg
    Member
    Post count: 80

    Thanks Twohid,

    When I try to access my product page now (and others) when logged in it goes into a redirect loop. Do you know what I need to do to fix that?

    Steps done so far

    The link in the first point of that article does not work but I googled it and found that I need to paste in the following to my wp config file which I have now done.

    define(‘FORCE_SSL_ADMIN', true);
    define(‘FORCE_SSL_LOGIN', true);

    I also installed that plugin (worryingly it says it hasn't been updated in 2 years..). I'm not sure what settings I need to use for that plugin so did not change anything from the default

    I then went to the dashboard page and ticked the secure posts box as advised.

    #52157

    towhid
    Participant
    Post count: 4505

    Please provide your login details by using this form: http://wedevs.com/provide-login-details/. I will have a look what is going wrong.

    Thank you ๐Ÿ™‚

    #52182

    Fearg
    Member
    Post count: 80

    Done, thanks Twohid.

    #52248

    Fearg
    Member
    Post count: 80
    This reply has been marked as private.
    #52283

    towhid
    Participant
    Post count: 4505

    Hello Fearg,

    I have fixed that upload issue. One of the plugin “Smart Currency Converter for Woocommerce” is creating the trouble. I have deactivated that plugin.

    Can you please check and let me know the result.

    Thanks

    #52286

    Fearg
    Member
    Post count: 80

    Hi Towhid,

    I just tried again but get the same error message (when using chrome)

    This webpage has a redirect loop

    ERR_TOO_MANY_REDIRECTS

    Please try logging in via the my-account page and then go to the products page (or any other vendor page on the dashboard) to recreate the issue

    #52291

    towhid
    Participant
    Post count: 4505

    Hello Fearg,

    I have tried to reproduce this issue but failed. You can disable all your plugins except Dokan and switch to a default theme of WordPress like – Twenty Twelve, Twenty Thirteen, Twenty Fourteen and let me know the results.

    Thanks

    #52372

    Fearg
    Member
    Post count: 80

    Hi Towhid,

    Its definitely not an issue related to plugin contention. I think I have it fixed now anyway, I disabled the HTTPS plugin and instead added the code below to my htaccess file. I also change http to https in my settings-> general worpress & site address ( I think I should have done both of these when I got SSL originally). Unticking “force http after checkout” also seemed to help.


    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.yoursite.com/$1 [R,L]

    Thanks for looking at it for me. If you see anything blatantly wrong in what I did above please let me know

    Fearg

    #52377

    towhid
    Participant
    Post count: 4505

    Hello Fearg,

    I am really glad to know that you have solved the problem successfully. I am going to mark the topic as resolved and closed.

    Thanks

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘An error occurred in the upload. Please try again later.’ is closed to new replies.