Home Forums Plugin Support WP User Frontend (Free Version) Can't get translation to work – continued

This topic is: resolved

This topic contains 24 replies, has 3 voices, and was last updated by  Jesper Wille 3 years, 7 months ago.

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #68816

    Jesper Wille
    Member
    Post count: 23

    Hi there –

    Apologies for letting this issue lapse over the summer vacation – I still haven't managed to fix the issue described in this (closed) thread:

    https://wedevs.com/support/topic/cant-get-translation-to-work/

    I super-hope you can help me out, it's basically the final issue I have to be able to test before committing to Dokan.

    Thank you in advance!
    ๐Ÿ™‚

    Best,
    Jesper Wille

    #68826

    Nayem
    Moderator
    Post count: 6480

    Hello Jasper,

    Did you rename your translation file correctly?

    #68832

    Jesper Wille
    Member
    Post count: 23

    Hi Nayem –

    I have tried naming it “wpuf” and “dokan”, neither of which have worked – are there any other possible naming constructions?

    ๐Ÿ™‚

    #68835

    Nayem
    Moderator
    Post count: 6480

    If you are using WP User Frontend then the file name should be wpuf-da_DA.mo. Put this translation file in the language folder of the plugin.

    Thanks.

    #68848

    Jesper Wille
    Member
    Post count: 23

    I have tried this filename – it didn't work… I am using the Dokan Lite plugin, and I have also tried dokan-da_DA.mo which also did not work..

    JW

    #68861

    Nayem
    Moderator
    Post count: 6480

    Please provide your login details by using this form: http://wedevs.com/provide-login-details/. I will have a look what is going wrong.

    Thank you ๐Ÿ™‚

    #68888

    Jesper Wille
    Member
    Post count: 23
    This reply has been marked as private.
    #68950

    Nayem
    Moderator
    Post count: 6480

    Can you please tell me that in which language the site should be translated?. Also please provide your FTP details here.

    Thanks.

    #68956

    Yeasin Arafat
    Moderator
    Post count: 96

    Hi Jesper,

    If you are using WP User Frontend then the file name should be wpuf-da_DK.mo . Put this translation file in the language folder of the plugin.

    Thanks.

    #68966

    Jesper Wille
    Member
    Post count: 23
    This reply has been marked as private.
    #68968

    Nayem
    Moderator
    Post count: 6480

    Your file name should be like this- wpuf-da_DK.mo.

    Thanks.

    #69996

    Jesper Wille
    Member
    Post count: 23

    Hi Nayem –

    I've finally had time to try again – sorry, it still doesn't work with that file name.

    I have tried opening the file and changing a text string I know the site uses (i.e. “No orders found!”, as seen on this page: http://jesperwille.com/silverhand/dev/my-orders/ – changed to “hello, no orders found!”), then saving the file and reloading the page, the text is still the same. It seems the site doesn't use the language file at all.

    Is it because I am using the free version – is multi-language a premium-only feature?

    Thank you!
    kindly,
    Jesper W.

    #69999

    Nayem
    Moderator
    Post count: 6480
    This reply has been marked as private.
    #70042

    Jesper Wille
    Member
    Post count: 23

    No, not trying to enable multi-language – just trying to implement Dokan's own translation feature into Danish language.

    The site I am working on is going to be regional so no problem – but I still want to ask, is multi-language support, i.e. WPML, something Dokan might support in the future?

    ๐Ÿ™‚
    Jesper

    #70143

    Nayem
    Moderator
    Post count: 6480

    Hello,

    Right now Dokan is not compatible with WPML. But we have plan to make it compatible with Dokan plugin in near future.

Viewing 15 posts - 1 through 15 (of 25 total)

The topic ‘Can't get translation to work – continued’ is closed to new replies.