This topic contains 4 reply and 2 voices, and was last updated by skone 6 years, 6 months ago
Viewing 4 Posts - 1 through 4 (of 4 total)
Author Posts
March 24, 2013 at 12:02 am 1466
skone I have my dashboard set up to show a custom post type using the dashboard shortcode [wpuf_dashboard post_type="product"] then I have my edit page set up with the edit shortcode [wpuf_edit] but when I click on 'edit' next to the relevant post I get the error "I don't know how to edit this post, I don't have the form ID" If I use the shortcode to my form instead then when I click edit the form comes up but none of the fields are filled in so it's like creating a new post instead of editing the existing one. Any help with how to fix this would be great. Thanks Update: Found the resolution to this in the FAQs in the documentation - just needed to go back to my old products and select the relevant form from WPUF form in the post edit screen. Should've read this first! Cheers!
March 24, 2013 at 12:14 am 1468
Tareq Hasan Tareq Hasan

Quoted from the docs:

Q. I get the message: “I don’t know how to edit this post, I don’t have the form ID”

Ans: When you create a post with the new version of WP User Frontend, a form ID is being attached to that post. It’s needed because you might have 10 forms and it doesn’t know which form should be used to edit that post.

For this problem with older posts, one thing you need to do. If you go the those posts edit screen in backend, you’ll see a meta box “WPUF Form”, select the form that should be used to edit the form.

The next question, is that means you created post with the form. But when you go to edit the post, the fields are blank?

March 24, 2013 at 12:32 am 1469
skone skone

Hi Tareq,

Thanks, I found that info in the FAQs and have made the updates now so it works nicely. It would be great to be able to do this by batch as it would take ages to do this one by one for a lot of posts.

I have a few additional questions. Let me know if you’d prefer me to create these as separate threads.

Uploading/Editing Additional Images

Another question I have is how to edit additional images attached to the post. On the free version of the plugin I uploaded additional photos as ‘attachments’ and they would just be uploaded to the post and I could edit them. But now on the premium version of the plugin there isn’t a field for attachments, just an image upload field in post area (which I don’t want) and custom fields which contain images (these are custom, not uploaded to the post as per using the media manager). Any advice on how I can do this?

Don’t Show Custom Fields on Front end

So when a new post is added, the custom fields show on the front end after the content. Is there a way to disable this? I want users to be able to add the information but I want it to only be visible on the backend and in the edit screens.

Thanks!

March 24, 2013 at 2:06 am 1470
Tareq Hasan Tareq Hasan

If you have questions about different requirements, create a new thread.

For batch form association with posts you could use some php, get all the posts and associate the form id to those posts. It’s simple because it’s a meta field _wpuf_form_id to those posts where it keeps the Form ID as reference. But there isn’t any batch process feature in the plugin right now.

Additional Images: In the free version, those images are only attached to the post. There wasn’t any reference to any custom fields for those attachments. In technical terms, attachments is a post type and those attachments parent post was set to those posts. But in the pro version, attachments were removed and custom fields are back to the scene. It’s kinda the same things happens. Those attachments parent is also set to those post and also those attachments are assigned to a custom field. So you could use the same old technique to show all those attachments that are attached to a post. So in a nutshell, you can still show all those attachments that are attached to a post, even they are saved in custom fields. Hope I am clear.

Custom fields in frontend: I guess you missed the Showing Meta Fields section in he doc.

There is also an global option display all the meta fields in your posts. Turning on the “Settings > General Options > Custom Fields in post” option will show all your posts custom fields in every post.

You just have to turn the option off.

March 24, 2013 at 9:48 pm 1489
skone skone

Thanks Tareq, I did actually read the documentation but I must not have understood some parts of it I guess!

With images, I just want them to be uploaded as they normally would if the user was using the media uploader, not as custom fields. The free version of your plugin does this nicely by using attachments. I will see if I can get something working for this but I might start a new thread to discuss further.

Cheers!

Viewing 4 Posts - 1 through 4 (of 4 total)