Home Forums Plugin Support WP User Frontend Pro Compatibility issues with Jigosho[

This topic is: resolved

This topic contains 8 replies, has 2 voices, and was last updated by  Webfreelance 5 years, 5 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #6489

    Webfreelance
    Participant
    Post count: 29

    Hi Tareq,

    I'm having an issue with Jigoshop and User Frontend Pro compatibility.
    Is there a fix for this?

    Thanks

    #6514

    Tareq Hasan
    Keymaster
    Post count: 2831

    What is the problem actually? I never tried jigoshop personally.

    #6532

    Webfreelance
    Participant
    Post count: 29

    When i activate Jigoshop it does not show the Jigoshop menu, and if you go into your active plugins and select settings on the Jigoshop plugin it says you do not have sufficient permission to access.

    #6686

    Webfreelance
    Participant
    Post count: 29

    Hi Tareq, Any update regarding this issue?

    #6700

    Tareq Hasan
    Keymaster
    Post count: 2831

    I haven't gotten the time yet to check the issue. Why not stick with WooCommerce, as it's a fork of Jigoshop? ๐Ÿ™‚

    #6704

    Webfreelance
    Participant
    Post count: 29

    Hi Tareq,

    The reason i haven't gone with WooCommerce is that i am already familiar with Jigoshop and have written a client user guide for it as well as purchased multiple add-on's.

    Even so i have given WooCommerce a try as i don't think this issue will be resolved in time and WooCommerce does the exact same thing.

    #7271

    Webfreelance
    Participant
    Post count: 29

    Hi Tareq, Any fix for this, still having issues.
    Id appreciate it if you could get back to me. Thanks

    #7345

    Tareq Hasan
    Keymaster
    Post count: 2831

    Open /class/settings.php, check line 51. Which is:
    [php]add_menu_page( __( ‘WP User Frontend', ‘wpuf' ), __( ‘User Frontend', ‘wpuf' ), $capability, ‘wpuf-admin-opt', array($this, ‘plugin_page'), null, 55 );[/php]

    Change 55 to 54, and this should solve the problem.

    Alternatively, you can change the jigoshop code. Open /jigoshop/admin/jigoshop-admin.php and change same way in the jigoshop_before_admin_menu() function.

    #7346

    Webfreelance
    Participant
    Post count: 29

    Thanks for getting back to me Tareq.
    I know your a busy guy.

    Will test it and give you feedback.
    Much appreciated

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Compatibility issues with Jigosho[’ is closed to new replies.