Home Forums Plugin Support WP User Frontend Pro Custom Post Type and Edit Post Bug

This topic is: resolved

This topic contains 10 replies, has 3 voices, and was last updated by  smchimps 5 years, 8 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #3909

    smchimps
    Participant
    Post count: 8

    Just upgraded to the Pro version and am unable to get custom post type forms working or the edit post option to be displayed on the post list.

    We have a custom post type of services that is selected in the form settings but whenever a user submits a services form it a new post is created instead of the custom post type services.

    When edit posts is enabled the list of posts does not display an edit option for users to access posts that have already been published.

    These are the two features were the motivation for upgraded to the Pro version. Thanks for any help you can provide!

    #3910

    Mahi
    Member
    Post count: 1555

    Hello,

    Free version and PRO version totally different . Please spend few times on PRO Documentation here .

    After that, you should be fine and DONOT use both plugins together.

    Let us know if you require help.

    #3911

    smchimps
    Participant
    Post count: 8

    Hey Mahi,

    I've uninstalled the free version before installing the Pro version. I've also read the documentation to no avail to solve the problem. Any help is appreciated.

    #3940

    Tareq Hasan
    Keymaster
    Post count: 2831

    As you've mentioned that you selected the correct post type in the form setting, that problem shouldn't happen. Do you have multiple forms and are you sure you are checking the right form?

    If the problem still occurs, we could investigate in your site if it's live. Post the login details as private reply.

    #4111

    smchimps
    Participant
    Post count: 8
    This reply has been marked as private.
    #4117

    Mahi
    Member
    Post count: 1555

    Hello @smchimps ,

    I just checked and post a service post. All working fine. I disabled few plugins. You were using few plugins like – gravity forms, redirect and others to complete same task !

    You might want to disable more plugins to keep site clean. I guess, other plugins were causing the issue.

    I will suggest you to take few moments with WPUF, what you are trying to do with others 4/5 plugins, this Only One plugin covers them all.

    Let us know if you have anything else to concern.

    Cheers.

    #4183

    smchimps
    Participant
    Post count: 8

    Just checked to see if everything is working. When trying to create a new post for custom post type services it does not create a post for the custom post type but for the default post type. Can you please look into why this feature is still not working? Thanks!

    #4187

    Mahi
    Member
    Post count: 1555

    Hello,

    Again – confirming custom post service is working fine.

    post is pending at backend for admin approval as you set it.

    and, i can see my service posts under My Account -> Services -> All Services

    Thanks.

    #4270

    smchimps
    Participant
    Post count: 8

    Sorry for the confusion… the problem is for non-admin users who try to create services post type. Instead of creating a services post type, a regular post is created when a services post type is submitted. I've setup a user with the contributor user level for testing and will follow up this message with a private one with the account details. Thanks!

    #4271

    smchimps
    Participant
    Post count: 8
    This reply has been marked as private.
    #4297

    smchimps
    Participant
    Post count: 8

    Found a new bug with the forms. When using the contact form type with the default option of publish a new post is created that cannot be deleted by the admin. If the default option is set to draft it can be deleted.

    Did you determine that the Dashboard Edit option will not work with GravityForms enabled? This was how we were originally taking registration applications (can't use your registration forms because we need to approve each new registration). Thanks!

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Custom Post Type and Edit Post Bug’ is closed to new replies.