This topic contains 12 reply and 3 voices, and was last updated by David 5 years, 9 months ago
Viewing 12 Posts - 1 through 12 (of 12 total)
Author Posts
December 29, 2013 at 11:07 pm 14027
David Something very odd is happening. I have 4 custom taxonomy; Language, Group, Level and Cost When I add these too the form, they all show up, but when I save 'group' disappears. BUT here is the odd part, it shows up on the form, but when I go back to the Form Edit..it is not there anymore. If I try and add 'group' again, it shows up, then disappears after I save, and then TWO 'group' selections are on the live form. I can send you user login info to see for yourself. It is very very odd. It only happens with the 'group' taxonomy. All for custom taxonomy were created the same. Please help; I love this pluign. Once I get it to work, I'm going to go for Dev License. Dave
December 29, 2013 at 11:24 pm 14028
Tareq Hasan Tareq Hasan

Is the form is very long? It might exceed the limitation of the database table field, but other than that, it shouldn’t happen.

You can provide your site url, user login and password. Mark your reply as Private reply to keep it safe.

December 30, 2013 at 3:29 am 14031
David David This reply has been marked as private.
December 30, 2013 at 12:52 pm 14041
Tareq Hasan Tareq Hasan

Can you check the password again? It’s not working for me.

December 31, 2013 at 1:19 am 14052
David David This reply has been marked as private.
December 31, 2013 at 2:20 am 14055
bhriv bhriv

Hi. You mention the user may have “exceeded the limitation of the database table field,”.
What is this limitation?

Whenever I upload a localhost version of my database to a live server my forms reset and show no fields. This only seems to happen if I have used the HTML element in the form. Forms that don’t include this HTML element seem to load up as expected.

Please help.

Thanks

January 2, 2014 at 6:07 pm 14101
Tareq Hasan Tareq Hasan

Hello Dave,

Sorry for replying late. Seems like it’s conflict between the plugin and the taxonomy, not a hard way though.

The tabs you see in form editor, has the CSS class group and it show/hides based on the class name. Since your taxonomy has the same name group and it’s adding a CSS class in that element and the tab functions is hiding every element that has the group CSS class. Will it be a trouble to change the custom taxonomy name to lesson_group may be? That should solve the problem.

January 3, 2014 at 4:08 am 14103
bhriv bhriv

Hi. I have the same problem – with the Fields disappearing. I have confirmed that they are not being hidden though – they are actually removed. I don’t have any conflicting CPT or Taxonomy names.
This happened when I moved a database from the local version to a live server. All of my fields were deleted.

Do you know how to solve this problem?

January 3, 2014 at 5:02 am 14104
bhriv bhriv

Solved my issue – for some reason having active Custom Taxonomies breaks the database when moving the database from a localhost server to a live server, or vice-versa.

By deactivating my Custom Taxonomies ( // commented out the code in my functions.php file) and then exporting and importing the database I was able to transport the database and it worked correctly.

I haven’t fully tested whether then re-enabling my Taxonomies after importing the database works – but it seems that it will.

Hope this helps someone out there…it was a nightmare for me to figure this out.

Ben

January 3, 2014 at 9:35 am 14109
David David

Hi Tareq. I tried changing all the ‘group’ references to ‘lesson_group’ in both the functions.php and the template; post-pagenavigatorv2.php

I didn’t change the Group icon of course…that is not relevant.

It didn’t work. I’m missing something…..where should I change it? in Functions.php? but where?

Thanks for your help..plug in is awesome. It did everything I wanted it to do. Just need to fix this part so I can build and style the forms better.

Thanks,
Dave

January 8, 2014 at 7:14 pm 14243
David David This reply has been marked as private.
January 9, 2014 at 1:01 pm 14258
Tareq Hasan Tareq Hasan

What I see is you have the taxonomy name group. Changing the label only wouldn’t work.

I don’t know who added the taxonomy, your theme or any plugin? If your theme, need to modify your theme. Find something like this: register_taxonomy( 'writer', 'book', $args );, here writer is your taxonomy name. Just change that bit.

Hope that helps.

January 26, 2014 at 6:52 pm 14786
David David

Changing the taxonomy worked. I had to change some other code in my template, that used that taxonomy too….but it worked. Thanks for your help.

Viewing 12 Posts - 1 through 12 (of 12 total)