Home Forums Theme Support Dokan Disable comments & get rid of the right sidebar

This topic is: resolved

This topic contains 13 replies, has 2 voices, and was last updated by  Nayem 3 years, 10 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #53506

    Loukia
    Member
    Post count: 87

    hello, i want t get rid of the right sidebar and disable comments

    #53523

    Nayem
    Moderator
    Post count: 6480

    Hello Loukia,

    To disable comment from a page please navigate to Wp admin->Pages-> Click on the quick edit page. Then you have to uncheck the checkbox for Allow comments on page. Please check the screenshot-

    From which page do you want to remove sidebar? Please provide a screenshot here.

    Thanks.

    #53554

    Loukia
    Member
    Post count: 87

    http://s9.postimg.org/qiiztc4an/2015_06_29_9_33_27.png

    the sidebar where it says search, archive and meta

    #53555

    Nayem
    Moderator
    Post count: 6480

    Please open Dokan theme folder/sidebar-home.php file. In this file you will get those codes-

     <aside id="search" class="widget widget_search">
                    <?php get_search_form(); ?>
                </aside>
    
                <aside id="archives" class="widget">
                    <h1 class="widget-title"><?php _e( 'Archives', 'dokan' ); ?></h1>
                    <ul>
                        <?php wp_get_archives( array('type' => 'monthly') ); ?>
                    </ul>
                </aside>
    
                <aside id="meta" class="widget">
                    <h1 class="widget-title"><?php _e( 'Meta', 'dokan' ); ?></h1>
                    <ul>
                        <?php wp_register(); ?>
                        <li><?php wp_loginout(); ?></li>
                        <?php wp_meta(); ?>
                    </ul>
    </aside>

    You have to remove those line.

    #53573

    Loukia
    Member
    Post count: 87
    This reply has been marked as private.
    #53575

    Nayem
    Moderator
    Post count: 6480

    Hello Loukia,

    In your dokan theme folder you will get this file- sidebar-product-single.php. In this file, you will get that same code. Remove that code and you will be done.

    <aside id="search" class="widget widget_search">
                    <?php get_search_form(); ?>
                </aside>
    
                <aside id="archives" class="widget">
                    <h1 class="widget-title"><?php _e( 'Archives', 'dokan' ); ?></h1>
                    <ul>
                        <?php wp_get_archives( array('type' => 'monthly') ); ?>
                    </ul>
                </aside>
    
                <aside id="meta" class="widget">
                    <h1 class="widget-title"><?php _e( 'Meta', 'dokan' ); ?></h1>
                    <ul>
                        <?php wp_register(); ?>
                        <li><?php wp_loginout(); ?></li>
                        <?php wp_meta(); ?>
                    </ul>
    </aside>

    Thanks.

    #53576

    Loukia
    Member
    Post count: 87

    but what is the code for the woocommerce product categories in order to place it there?

    #53578

    Nayem
    Moderator
    Post count: 6480

    Please navigate to Wp-admin->Apperance->Wdiget and place WooCommerce product category widget in the single product page.

    Thanks.

    #53579

    Loukia
    Member
    Post count: 87

    Is not working.
    Basically this issue occurs to the category, subcategory and single product pages.

    #53581

    Nayem
    Moderator
    Post count: 6480

    Actually what you are trying to insert in the single product page? Please make me clear about that.

    #53582

    Loukia
    Member
    Post count: 87

    the Woocommerce Product Categories Widget

    #53584

    Nayem
    Moderator
    Post count: 6480

    I have mentioned they way to put the widget into the page. Now is is not working?

    #53586

    Loukia
    Member
    Post count: 87

    http://s30.postimg.org/3nb1tskjl/Okay.png In this picture you will see the widget i want to place. In the single product page works fine. forgive me about my mistake. is not to woocommerce category widget is the Dokan product category widget.

    now in the subcategory and category page the problem is still there. here is the screen shot. on the left site i still have search bar, archives and meta sidebars

    http://s9.postimg.org/rxe4ytk8v/wrong.png

    I hope i made my self clear this time

    #53682

    Nayem
    Moderator
    Post count: 6480
    This reply has been marked as private.
Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Disable comments & get rid of the right sidebar’ is closed to new replies.