Home Forums Theme Support Dokan Dokan theme translating

This topic is: resolved

This topic contains 7 replies, has 3 voices, and was last updated by  Sekander Badsha 4 years, 5 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #29779

    Andrey
    Member
    Post count: 22

    Not localized theme.

    Put the translated files PO and MO in /wp-content/languages/themes folder, as the title of the theme and locale (dokan-ru_RU.po, dokan-ru_RU.mo)
    Put the translated files PO and MO in /wp-content/themes/dokan folder, as locale (ru_RU.po, ru_RU.mo), and has not received the transfer topics.

    Note that in the theme there are several translations of phrases, searching sources realized that they pulled out of the localization file Dokan Plagin (/wp-content/languages/plugins). Tried to combine PO files into one file localization plugin, and lo!

    The theme has been translated! What's the problem? Why does not the translation of the theme folder?

    #29834

    Nayem
    Moderator
    Post count: 6480

    Hello Andrey,

    I am not clear about your problem. Are you having issues with linking the translation files?

    If yes, Please follow this doc http://docs.wedevs.com/translate-dokan-plugin/ and let me know if this works or not.

    Thank you ๐Ÿ™‚

    #29840

    Andrey
    Member
    Post count: 22

    Hello! The problem I mentioned in the relevant subject. The theme is translated in accordance with the rules of the WP. Dokan is not the first theme, which I translated, and wrote on the forum, was added files mo and with the name of the theme (dokan-ru_RU.po and dokan-ru_RU.mo) in /wp-content/languages/themes. But I… For some reason, the theme translated after I added the data from the file dokan-ru_RU.po Theme in dokan-ru_RU.po Plugin, i.e. combine both files into one file and put it in /wp-content/languages/plugins.

    I installed WP 4, this define(‘WPLANG', ‘ru_RU'); in the configuration file set is not required because the language setting of the site are established in the admin panel.

    #29961

    Andrey
    Member
    Post count: 22

    Plugin successfully translated. Theme is not translated! Solve the problem already!

    #30297

    Sekander Badsha
    Member
    Post count: 2067

    Hello Andrey,

    If your problem is solved, please mark this topic as resolved.

    If not, then please be specific about where you got stuck.

    #30320

    Andrey
    Member
    Post count: 22

    Are you kidding? Where exactly? Several times already described the problem – Plugin translates wonderful translation theme does not work. File is placed in the / wp-content / languages / themes /, like all normal language files in the language folder and Dokan themes / wp-content / themes / dokan / languages, and a file called Dokan-ru_RU and just ru_Ru. Installed WordPress 4, the language of the site is selected via the admin panel, but for the purity of the experiment found in the configuration file used by the locale.

    #30432

    Andrey
    Member
    Post count: 22

    You do normal people? Where is the support?? The stated problem has already occurred, and there is YOUR fault!! Thank you to the kind person who found the solution to this problem
    http://wedevs.com/support/topic/incomplete-translation/#post-30431

    #30866

    Sekander Badsha
    Member
    Post count: 2067

    You said

    Solve the problem already!

    That is why I was confused about if you have solved the problem or not and I asked.

    Glad to know that finally you got to solve it.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Dokan theme translating’ is closed to new replies.