Home Forums Plugin Support WP Project Manager Pro Email links still not clickable

This topic is: not resolved

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by  towhid 4 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #35551

    Paul
    Member
    Post count: 1

    In a previous forum post there was a workaround to creating clickable links in the outgoing emails by adding add_filter( ‘cpm_get_content', ‘make_clickable' ); in cpm.php after line 421. I never tested it so I don't know if it would have worked.

    After updating to 0.5.4 I looked and that line has been added to cpm.php on line 457. However, the links are still just plain text in emails and are not clickable. I've set email settings to HTML Mail (I had to manually add p-tags for formatting) but it's still not working.

    Is there something I'm missing?

    Thanks!

    #35607

    towhid
    Participant
    Post count: 4505

    Hello Paul,

    I am not clear your question. Can you please let me know where you want to put the email link. Is it in message content area? Also can you provide me a screenshot.

    Thank You ๐Ÿ™‚

    #35663

    Paul
    Member
    Post count: 1

    Hello,

    The outgoing emails are automatically sent by the system for New Project, New Comment, etc. The email arrives with an included “Permalink:” followed by a link to the referenced item, but the link is plain text, not a hyperlink.

    At first, the email was just one long line of text with no breaks. I fixed that by adding p tags in the email settings.

    email settings

    But, the link is still plain text, not a hyperlink.

    email example

    The recipient has to copy and paste the link rather than just being able to click on it.

    I tried adding a href code to the %PROJECT_URL% in the Email Settings but that doesn't seem to work,either.

    This was supposedly resolved in Post #24138 and the PHP filter was added in 0.5.4

    Any further help would be greatly appreciated.

    #36104

    towhid
    Participant
    Post count: 4505

    Hello Paul,

    I have reproduced this issue and failed. I can see the project permalink in user email(I have tested). Please let me know which version you are using for WP Project Manager pro? If you are not using latest version please update then. After than hope everything will be alright. If the problem still persists, please let me know I will here to help you.

    Thank You ๐Ÿ™‚

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Email links still not clickable’ is closed to new replies.