Home Forums Plugin Support WP Project Manager Pro Frontend seems hard to setup

This topic is: resolved

This topic contains 12 replies, has 4 voices, and was last updated by  arzelia 5 years, 1 month ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #17343

    arzelia
    Member
    Post count: 57

    Hi there seems to be a lack of documentation on how to set up the frontend. All I could find in the readme.txt file was to place [cpm] on the projects page. Then digging deeper into forums [cpm_my_task] for Tasks and Calendar [cpm_calendar]. However the Calendar page just shows the text “Calendar” and does not display the actual calendar.

    There is a login form that shows up when trying to access the wp project manager areas in frontend. However upon entering login information, it simply reloads and shows the login form again and does not log you in. The url upon reload shows: http://www.website.com/login/?redirect=http%3A%2F%2Fwww.website.com%2F

    I'm using the Invoice addon which does not seem to work well on dark background pages. The text on several columns are actually white on white and only shows if I highlight the row. Could you point me to which file I can edit for these colour changes?
     photo wppm-invoice.jpg

    Also I am getting a double title on the pages which I would like to get rid of. It shows the page title and also menu navigation title, then the WP Project Manager's title. Can I just get it to show My Tasks and not display the page title?
     photo wppm-tasks.jpg

    Clicking in to the individual project, the formatting seems pretty messy and the tabs weren't aligned properly. They were stacked vertically instead of horizontally. Again, it'd be nice if you could point me to a file or class that I could edit to fix that.
     photo wppm-projects-sub.jpg

    #17367

    arzelia
    Member
    Post count: 57

    Managed to fix the color issues. pm_invoice's style sheets were pretty hidden and somehow not listed in wordpress admin dashboard's plugin editor. But the misalignment of tabs has be baffled, not sure how to fix that one. The task page also has some pretty evident misalignment as shown below. Any help would be appreciated.

     photo wppm-tasklist.jpg
    (the task title went so far down away from the checkbox, and the comments box became broken)

    Also, where can I go to edit the system generated starting invoice number?
    (ref:http://wedevs.com/support/topic/wp-project-manager-with-addons/)

    #17368

    arzelia
    Member
    Post count: 57
    This reply has been marked as private.
    #17396

    Tareq Hasan
    Keymaster
    Post count: 2831

    Seems like your theme is putting
    tags on the vertical tabs, that's why they are vertical. Might be shortcode handling problem on theme, I've seen this kind of things many times now.

    #17400

    arzelia
    Member
    Post count: 57

    Sorry, what tags? the box in your post looks empty. Do you happen to mean “br” tags? Any idea how to fix it since you've seen it many times.

    #17409

    Tareq Hasan
    Keymaster
    Post count: 2831

    Yes, sorry. Seems like “br” tag was garbled when posted.

    I can't say it from here as I don't know how the theme is coded. If it's a premium theme, ask them about it.

    #17457

    arzelia
    Member
    Post count: 57

    I have asked the theme developer and still waiting on response. I've also googled a bit and apparently it is a wordpress issue of inserting unwanted “p” and “br” tags.

    This page below says the plugin should include the following code to avoid getting those additional tags appearing:
    remove_filter('the_content', 'wpautop');
    http://wpusersplugin.com/3736/wp-themes-add-unwanted-html-break-tags-between-links/
    But no idea where to insert this so searched for something else.

    I also tried another fix which works perfectly, which is to enclose cpm with raw shortcodes.
    [raw][cpm][/raw]
    this seems to remove all the unwanted tags!

    #17474

    Tareq Hasan
    Keymaster
    Post count: 2831

    Great, that would fix it for now ๐Ÿ™‚

    #17535

    Greg
    Member
    Post count: 8

    Using the [raw] shortcode then just shows the [cpm] shortcode as text.
    I just want the same page formatting I see in the dashboard.

    This is what I see now as shown on wordpress page

    #17539

    Greg
    Member
    Post count: 8

    Is there a way to set [cpm] to display a specific project?

    #17545

    Nizam Uddin
    Keymaster
    Post count: 670

    Yes, to do this first you need to find project ID.
    To get project ID, hover your mouse over a project. You will see a URL something like this:
    http://example/wp-admin/admin.php?page=cpm_projects&tab=project&action=single&pid=1750

    1750 is your project ID.

    Then use the shortcode [cpm id=1750]

    #17553

    Greg
    Member
    Post count: 8

    Perfect.
    Thanks!

    #17604

    arzelia
    Member
    Post count: 57

    you need to enter the raw code in the text editor instead of the visual editor (tabs are top right of the input box) under edit page.
    [raw][cpm][/raw]

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Frontend seems hard to setup’ is closed to new replies.