This topic contains 20 reply and 6 voices, and was last updated by Sekander Badsha 4 years, 10 months ago
Viewing 15 Posts - 1 through 15 (of 20 total)
Author Posts
August 19, 2014 at 10:47 am 25487
Sekander Badsha i have purchased DOKAN theme version 1.0.2 i m facing one issue regarding seller registration page on front end side in wordpress. so when i click on the radio button i m seller then other fields are not opening. second issue is even if i click the radio button i m customer then also register button is not working. there is no effect after click on the register button. so i would request DOKAN theme support forum to solve my issue . thanks in advance.
August 21, 2014 at 7:57 pm 25652
Sekander Badsha Sekander Badsha

Hello Christian,
The current version of Dokan is 1.0.6 Please update and see if the issue remains or not. And also in the WordPress settings, check if you have turned on “Anyone Can Register”.

August 22, 2014 at 2:59 pm 25675
Christian Christian

Hi,
thanks for reply.

i have purchased dokan theme which have version 1.0.5 and there is no any update button is there.
also in wordpress backend i already have turned on anyone can register.

when i installed dokan theme in the local environment seller registration form works good.
In local environment seller registration is working on the frontend side.

but when i installed it on the live environment it is not working.
so what will be the problem coming, i dnt know.

can u please guide me here.

also in my localhost how to assign store URL in seller registration form?

please explain me how to assign seller store url in frontend side.

waiting for your reply.

thanks in advance.

August 25, 2014 at 3:52 pm 25811
Sekander Badsha Sekander Badsha

Hello Christian,
Without knowing the problem in detail, we can’t give you ant solution. Please brief about what you get when you try to register. Have you started from scratch online? or Restored your local files online?

When a seller registers from the front, he gets and option to set his shop URL.

August 26, 2014 at 10:47 am 25870
Christian Christian

Hi,

thanks for the reply.

when i open sign up page, so on that page two option will be there. options are I m seller and I m customer.

when i select option I m seller then other fields are opening in my installation on localhost,but on live installation this is not working. so other fields are not opening when i select option I m seller.

i restored local files online also.
the version of wordpress and the version of woocommerce plugin which i have on my localhost installation, that same version of wordpress and woocommerce is installed on my live server.
so I m not getting why it is working on localhost only,not on the live.

then i try my installation on one another server. then this issue is working fine.
so is there any problem on host side?

and also tell me how to set seller store url.
for that is there any type of permalinks settings is required or not in wordpress.

waiting for your reply.
thanks in advance..

August 26, 2014 at 11:26 am 25874
Christian Christian

Hi ,

when i set store url then url is like domain/store/(any name)
but when i try to click on visit your store link then i get error that page not found.
so how to open seller store page please let me know.
waiting for your reply.
thank you.

August 27, 2014 at 10:24 am 25919
Christian Christian

Hi,

I assign seller store url on the frontend side, when i try to open that url on the frontend side i got internal server error.

so where is thee problem I m not getting it.
is there any problem in the permalink settings side in wordpress?

please help me in this issue.

thank you in advance.

August 27, 2014 at 5:03 pm 25944
Sekander Badsha Sekander Badsha

Hello Christian,
Please check if you have turned on any one can register from WordPress settings and set the permalink structure to “postname” and WooCommerce permalink to “product-name”. And see if the issue is solved or not and let me know the result.

August 28, 2014 at 10:11 am 25988
Christian Christian

Hi,

thanks for your reply.

when i tried to set the permalinks settings to postname and woocommerce permalink to product-name, then i got one notice that
If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all


RewriteEngine On
RewriteBase /wp/
RewriteRule ^index\.php$ – [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wp/index.php [L]

in my installation.
so i set permission to 755 for my .htaccess file and i also add these rules in the .htaccess file.
but after that when i tried again to set these in permalink settings then again i got the same notice.
so please let me know.
waiting for your reply.
thank you in advance.

August 30, 2014 at 3:29 pm 26072
Sekander Badsha Sekander Badsha

If you have any security plugin, please deactivate that. If you don’t have any security plugin or disabling that doesn’t help, you should talk to your hosting provider.

September 1, 2014 at 9:39 am 26134
Christian Christian

Hi,

thanks for your reply.
there was some permission problem in my .htaccess file,but now my issue is resolved of seller store page at frontend side.

thank you again.

November 2, 2014 at 1:13 pm 29580
FARHAN FARHAN

Hi
We have purchased your theme. In seller registration, the store url is not working. Please assist ASAP.

November 8, 2014 at 3:18 am 29972
Sekander Badsha Sekander Badsha

Hello Farhan,

Please follow the solutions I mentioned above.

Thank you 🙂

November 8, 2014 at 3:21 am 29973
FARHAN FARHAN

I am sorry, what do you mean by “…solutions i mentioned above”. May be
you forgot to attach the message.
Regards
Farhan.

November 12, 2014 at 9:58 pm 30315
Sekander Badsha Sekander Badsha

I am sorry that you did not get the above discussion.

The proble is coming from WooCommerce.

If you are using any other theme than Dokan, then follow A and B both. If you are using Dokan theme, then only follow B.

A. Make a folder named woocommerce inside your theme folder and inside that, you have to copy paste the form-login.php file. You can find the form-login.php in the dokan theme folder -> woocommerce -> myaccount.

B. Open the form-login.php and go to line number 97. You will see something like
<?php wp_nonce_field( 'woocommerce-register', 'register' ); ?>.

You have to remove the register from that line. So it will look like
<?php wp_nonce_field( 'woocommerce-register' ); ?>.

Hope everything will work fine. Please check and let me know.

November 13, 2014 at 2:05 pm 30376
FARHAN FARHAN

Hi,

I have tried all the possible solutions you have given in this thread. They are below,

1. We dont have any security plugin enabled.
2. Anyone can register is enabled in admin settings.
3. We are using dokan theme. And changed the line < ?php wp_nonce_field( 'woocommerce-register' ); ?>. as you said.
4. I even write the .htaccess code as you mentioned above.

Nothing works. Please help me out to fix the store url problem. I am not much familiar in writing rewrite rules.

Viewing 15 Posts - 1 through 15 (of 20 total)