Home Forums Theme Support Dokan Inventory Bug after updating to 2.01

This topic is: not resolved

This topic contains 11 replies, has 3 voices, and was last updated by  Nayem 3 years, 11 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #38915

    Larry
    Member
    Post count: 22

    Big thanks for the work you have done so far on the inventory saving bug. It seems to be working 100% when adding or editing a simple product.

    However I still have the same issues when adding/editing a variable product and trying to save. This is what I've found so far.

    1. Inventory Tab > Enable stock at product level. Always checked even after saving as unchecked.
    2. Inside each variation I cant change out-of-stock to in-stock. Saving revert the option back to out-of-stock

    Thanks again. Looking forward to this fix next ๐Ÿ™‚

    #38923

    Nayem
    Moderator
    Post count: 6480

    Hello Larry,

    1. Actually when you will use variation for product then inventory stock management will not work. You will get manage stock option in the variation tab.

    2. Please make sure that you have enable manage stock in the variation product. Please check the screenshot-

    Please check and let me know. Thank you ๐Ÿ™‚

    #39021

    Larry
    Member
    Post count: 22

    I've recorded a video outlining the issues I am having. I'm getting annoyed that you keep trying to say there is nothing wrong. I've been working with woo long enough to know when stuffs not working how it should. When you set an option, and press save, and that option doesn't save. Then there's something wrong.

    Video link: http://vendori.co.nz/v-errors.mp4

    #39029

    Mohammed Jawad
    Member
    Post count: 69

    Hey mate,

    Having the same issue as you. Furthermore this issue as well:

    1) If you delete a variation and click update product the variation does not delete and re appears upon refresh.

    Please fix soon, critical flaw.

    Many Thanks

    #39031

    Mohammed Jawad
    Member
    Post count: 69

    Hi again,

    After fiddling with it mate I've noticed that its our mistake and no fault of Dokan. When you check ‘Manage Stock', you need to enter ‘Stock Qunatity' before changing to ‘In Stock' and updating product!

    However, deleting variation is still an issue for me.

    Many Thanks

    #39032

    Larry
    Member
    Post count: 22

    Correct. This is normal. But when I untick manage stock, the in stock option doesnt save as it should with woocommerce.

    Also wont let me untick manage at product level when using a variable product. Again this is standard operation with a woo site.

    To recap though. The issues I have are not that it doesnt work, its that it doesnt save the options I set, via the sellers dashboard, updating manually via the admin backend saves as needed.

    I've also confirmed your variable option error, re not delting after being saved. All seems to be the same underlying error causing these. Options aren't being set on save.

    #39033

    Mohammed Jawad
    Member
    Post count: 69

    Hi,

    Oh right, fair enough. Seems like a saving issue then, will have to wait for the developers to get back on this one. Furthermore, there is a formatting error as well. I have added an image which now hide the checkboxes. See this:

    http://cl.ly/image/1n0z2d0l2W1T

    Many Thanks

    #39041

    Larry
    Member
    Post count: 22

    Interesting. I'll keep an eye out for that one.

    #39099

    Nayem
    Moderator
    Post count: 6480

    Hello Larry,

    I have to discuss with our developer team about this. They are now in weekend. They will be available from tomorrow. I will inform you about the discussion with them tomorrow. Please keep patience.

    Thank you ๐Ÿ™‚

    #39164

    Nayem
    Moderator
    Post count: 6480

    Hello Larry,

    I have discussed with our developer team.

    1. In the inventory tab when you have disable stock management option after updating it will remain as enable. We have fixed this. You can fix it by replacing those code. Please open Dokan plugin/includes/wc-functions.php file. In line number 733-736 you will find see this code-

    if ( ! empty( $_POST['_manage_stock'] ) ) {
          $manage_stock = 'yes';
          $backorders   = wc_clean( $_POST['_backorders'] );
    }

    You have to replace this code with these-

    if ( ! empty( $_POST['_manage_stock'] ) && $_POST['_manage_stock'] == 'yes' ) {
               $manage_stock = 'yes';
               $backorders   = wc_clean( $_POST['_backorders'] );
    }

    2. In the variation tab you have said that when you have disable manage stock it does not save the stock status. This system is coming from WooCommerce. If you want then you can check from backend. You have to Enable manage stock to save the stock status.

    Thank you ๐Ÿ™‚

    #39225

    Larry
    Member
    Post count: 22

    I added that first section of code. Seems to have fixed the main inventory tick/untick saving issue when editing a variable product. Thanks..

    The second issue needs to be looked at again. I've tried setting the product to “instock” without ticking “manage products” inside my admin backend dashboard, and these settings saved fine, see attached after updating the product.

    http://awesomescreenshot.com/01f4mri65d

    When I try to do this via the front-end sellers dashboard, every time I try and save I lose the settings and it reverts to “out of stock” after saving as per the video i sent you in one of my earlier posts.

    #39226

    Nayem
    Moderator
    Post count: 6480

    Hello Larry,

    I have tested in backend but it was not saving. I am using WooCoommerce v2.3.6.

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Inventory Bug after updating to 2.01’ is closed to new replies.