Home Forums Plugin Support WP User Frontend (Free Version) Issue when suscriber

This topic is: not resolved

This topic contains 3 replies, has 4 voices, and was last updated by  Mahi 5 years ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9637

    powebco
    Participant

    Hi,

    Thanks for this great plugin!

    I have an issue. When a registered user update his profile, he is redirect to the login page (http://website.com/login – I'm using theme my login) where users see 3 links (dashboard,Profile and Log Out). The dashboard link links to http://website.com/wp-admin (instead of http://website.com/dashboard) and the profile link links to http://website.com/wp-admin/profile.php (instead of http://website.com/author/author-name/).

    Therefore they see the wp backend when clicking on these links which is going away from the purpose of everything being front-end. I tried to limit access the admin area to only admins but users see the message: “Access Denied. Your site administrator has blocked your access to the WordPress back-office.”

    Thanks for your help,

    Ben

    #9700

    Tareq Hasan
    Keymaster
    Post count: 2831

    Sorry for the delay.

    Activate user links (Enable Custom User Links) module of theme my login plugin and you will be able to change those link urls and it should solve your problem.

    #15250

    Serkan
    Member
    Post count: 4

    I activated user links module of theme my login but it doesn't work. Then I activated the user redirection and solved the “Access Denied. Your site administrator has blocked your access to the WordPress back-office.” problem. I can access to my dashboard without this message now.

    However, this partially solves the problem as custom user links should be activated otherwise it seems to be a problem since I can't hide WP dashboard even with the WP Hide Dashboard plug-in.

    Can you please tell me why custom user links isn't working and how I can hide WP dashboard?

    #15302

    Mahi
    Member
    Post count: 1555

    you can prevent users from using wp-admin area from WPUF -> Settings -> under general settings ->Admin area access -> Admins Only

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Issue when suscriber’ is closed to new replies.