Home Forums Plugin Support WP User Frontend Pro Issue with Adding a Product with Payments Activated

This topic is: not resolved

This topic contains 4 replies, has 3 voices, and was last updated by  rkingw 5 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #14753

    rkingw
    Member
    Post count: 5

    I noticed an issue after adding a product with Payments activated. Using Woo Commerce.

    Here's the situation…I add a product, and get taken to the Select Payment Page. Let's say something then interrupts the payment process (browser crashes, user hits backspace key, etc) so the Paypal transaction never takes place. I then go to my Dashboard, and see the product I just added. The Status column says “Awaiting Approval”, and Payment column says “Pay Now”. When I click on the “Pay Now” link, I get taken to the Product Details page, NOT to the Select Payment Page.

    Shouldn't clicking the “Pay Now” link take a user to the Select Payment Page so they can complete the payment process?

    Thanks so much!
    Rick

    #14754

    Tareq Hasan
    Keymaster
    Post count: 2831

    Yeah, it should go to the payment page and usually does. You've selected payment page in plugin settings right?

    #14755

    rkingw
    Member
    Post count: 5

    Yes, I've selected my Payment page in the settings.

    The payment process itself works fine. I can add a product, pay through Paypal, then return back to my site. It's only if the payment process doesn't complete that I noticed the issue. If the product has a status of Awaiting Approval, then the Pay Now link goes to the Product Details page, not the Select Payment page.

    #14757

    Mahi
    Member
    Post count: 1555

    Pay Now button should visible only on Dashboard page, not on product page neither select payment page!

    #14759

    rkingw
    Member
    Post count: 5

    The Pay Now button is visible on the Dashboard. The problem is that the Pay Now button links to the Product Details page, and not the Payment page.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Issue with Adding a Product with Payments Activated’ is closed to new replies.