Home Forums Theme Support Dokan Logging in does NOT populate customer shipping details

This topic is: not resolved

This topic contains 13 replies, has 2 voices, and was last updated by  Nizam Uddin 4 years, 8 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #28320

    Neen Monty
    Member
    Post count: 72

    I have just installed Dokan from scratch for the FOURTH time. And am testing again. It appears to be full of bugs

    I tried creating an order. I then logged in, but the shipping address did not populate. That is, I STILL had to enter my shipping address. Or rather enter the BILLING address and then UNTICK the box that says ‘ship to different address'

    Clearly a cumbersome and pointless checkout process. The whole point of having an account is that you don't have to enter all this information each time. Please fix this.

    thanks
    Neen

    #28324

    Nizam Uddin
    Keymaster
    Post count: 670

    Hello Neen
    Extremely sorry for inconvenience! Please download all the latest version of theme & plugin then try this documentation http://docs.wedevs.com/upgrade-to-dokan-plugin/ and let us know the result. If problem exist. Please send us your site credential using this form http://wedevs.com/provide-login-details/ so that we can investigate the problem. Thank you..

    #28431

    Neen Monty
    Member
    Post count: 72

    I have all the latest versions, but I only have the plugin installed on localhost. I have retested though, and this time the billing address populated, but not the shipping address. I want to get all the bugs fixed before I install it on the live site. I don't want google indexing it until as is. Is there a way to hide the plugin from public users? and google?

    #28435

    Nizam Uddin
    Keymaster
    Post count: 670

    All shipping settings are coming from WooCommerce. Please check the WooCommerce settings. That same products are running in our demo environment. Please check our demo http://demo.wedevs.com/dokan . If you found same problem here then let us know. Or create a subdomain for demo purpose upload the data there so that we can investigate the problem. Thanks for understanding..

    #28440

    Neen Monty
    Member
    Post count: 72

    I tried the demo, but I couldn't check out at all on the demo page. Just gave me a blank page. Can you confirm that you can complete an order on your demo page?

    I have checked the woocommerce settings, and it is set to default to the shipping address. But the shipping address does not populate?

    #28445

    Nizam Uddin
    Keymaster
    Post count: 670

    Someone changed the cart and checkout page. Please try now. Thank you..

    #28446

    Neen Monty
    Member
    Post count: 72

    I just tried. The bug is on your demo page as well. I created a user, then placed an order. Logged in while checking out, and none of the fields populated. It doesn't work.

    #28476

    Nizam Uddin
    Keymaster
    Post count: 670

    Maybe i am missing something to understand, please give me a screenshot. Thank you..

    #28494

    Neen Monty
    Member
    Post count: 72

    Seriously? What's not to understand?

    1. Create a user.
    2. Log Out!
    3. Order something.
    4. Go to checkout. The checkout will prompt you to log in if you have an account
    5. Log In.
    6. The shipping fields and billing fields DO NOT populate. You have to fill in all those details yourself. Which defeats the purpose of having an account or logging in.

    I will try to get a screen shot, but I think its pretty simple. If you try it on the demo site its pretty clear. I actually HAVE a job, its not my job to test your application, that I paid a large sum of money for. Please take a look. I have spent many hours testing this thing.
    thank you
    Neen

    #28503

    Nizam Uddin
    Keymaster
    Post count: 670

    Hello Neen
    Its not a bug for Dokan! Its coming from WooCommerce & Its WooCommerce feature. If you have saved billing information then it will be automatically populated. After creating user, have you updated billing & shipping information? If you update billing information from your account it should work. I just tired and its working. Dokan is doing nothing here all are coming from WooCommerce. Thanks for understanding..

    #28504

    Neen Monty
    Member
    Post count: 72

    It didn't work on your demo site tho? Yes, I populated both billing and shipping (with junk data but still) You should be able to see it there. What versions of word press and woocommerce is your demo running please?

    #28508

    Nizam Uddin
    Keymaster
    Post count: 670

    Please see the screenshot its working for me

    WordPress 3.9.2 & WooCommerce 2.2.4

    #28509

    Neen Monty
    Member
    Post count: 72

    Did you have to uncheck the ‘Ship to a different address' checkbox? And is this a new account you created just before the order, or a previous account. I don't know why, but populates teh shipping address teh second time. Not the first. And I have to manually uncheck the checkbox or it fails on ‘Place order'

    #28511

    Nizam Uddin
    Keymaster
    Post count: 670

    Yes i unchecked the shipping address. I created account before order then updated billing address from profile then i ordered.
    Actually we can't edit WooCommerce core file as the feature is coming from WooCommerce. More than 4M website is using WooCommerce. If you feel this is problem for you then you can report them. Thanks for understanding..

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Logging in does NOT populate customer shipping details’ is closed to new replies.