Home Forums Plugin Support WP User Frontend Pro Obligatory fields not working for taxonomy entry

This topic is: not resolved

This topic contains 11 replies, has 3 voices, and was last updated by  Karel 4 years, 6 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #28973

    Karel
    Member
    Post count: 9

    Please note that we saw that when e.g. we put a taxonomy entry as obligatory on the frontend it does not work as it allows users to not select categories and still submit content…

    See our page at http://digiplace4all.eu/get-and-give-one-to-one-support/ where the first two options are obligatory, but still submissions can be done without selecting them.

    #29036

    Nayem
    Moderator
    Post count: 6480

    Hello Karel,

    Please check the following :

    1. You have the latest version of WordPress.
    2.You have the latest version of user fronted pro which is 2.2.6.
    3. You have marked the field as required.
    If all of the above are done and the problem is still happening please let me know.

    Thank you πŸ™‚

    #29139

    Karel
    Member
    Post count: 9

    Hello,

    While I was on your website I see no way to update the current pro plugin or download the new version. I have paid for the version I have now 2.2.3, so I would need the newer version a syou indicated. However I see no way to do an upgrade.

    Best regards,
    Karel Van Isacker
    =============================
    PhoenixKM BVBA
    Mr. Karel Van Isacker
    Projects & Business Developer
    Amersveldestraat 189
    8610 Kortemark
    BELGIUM
    Mobile: (B) +32 496 334056
    E-Mail: karel@phoenixkm.eu
    Skype: karel.phoenixkm
    URL: http://www.phoenixkm.eu
    =============================

    #29141

    Karel
    Member
    Post count: 9

    I found the update file, however how do I update the current version? Deactivate and rename the directory of the old one, and install the new one?

    Best regards,
    Karel Van Isacker
    =============================
    PhoenixKM BVBA
    Mr. Karel Van Isacker
    Projects & Business Developer
    Amersveldestraat 189
    8610 Kortemark
    BELGIUM
    Mobile: (B) +32 496 334056
    E-Mail: karel@phoenixkm.eu
    Skype: karel.phoenixkm
    URL: http://www.phoenixkm.eu
    =============================

    #29165

    Nayem
    Moderator
    Post count: 6480

    Hello Karel,

    You can update your WP User Frontend plugin just like you update a regular plugin from Dashboard. Please navigate to Dashboard->Update->Plugins and then update your plugins.

    Thank you πŸ™‚

    #29170

    Karel
    Member
    Post count: 9

    Hello,

    Seems it was a problem with WordPress regarding the update. However
    not all taxonomies were working after the update (category, website
    url, etc.) so all forms have to be remade. Unfortunately the checkbox
    function does not want to display on the frontend anymore, so I had to
    resort to a multiselect which i like to avoid at all cost due to
    accessibility issues.

    See the page at http://digiplace4all.eu/case-studies-new-entry/.

    Any help would be appreciated as i need to deliver end of this week.

    Thanks, Karel

    2014-10-27 15:12 GMT+02:00 weDevs Team :

    #29228

    Nayem
    Moderator
    Post count: 6480

    Hello Karel,

    Please provide your login details by using this form -http://wedevs.com/provide-login-details/. I will have a look what is going wrong.

    Thank you πŸ™‚

    #29238

    Karel
    Member
    Post count: 9

    I just did so.

    Regards, Karel

    2014-10-28 8:40 GMT+02:00 weDevs Team :

    #29244

    Nayem
    Moderator
    Post count: 6480

    Hi Karel,

    I tested your issue and here its working fine. Checkbox function is displaying on the frontend. I send you a screenshot of this. Please check and let me know.

    #29246

    Karel
    Member
    Post count: 9

    Hello,

    we tested it right now on mozilla Firefox 31.0 and Chrome
    38.0.2125.111 m, it does not show any of the checkboxes when
    associated with a selection type (child of…). Only multiselect shows
    properly… so this issue is still not ok.

    E.g. Get and give peer support form displays on
    http://digiplace4all.eu/get-and-give-one-to-one-support/ (login
    required) but will NOT display checkboxes, only the multiselect option
    works.

    Regards, Karel

    2014-10-28 11:37 GMT+02:00 weDevs Team :

    #29450

    Sekander Badsha
    Member
    Post count: 2067

    Hello Karel,

    I have fixed the issue for you. I have modified wpuf-functions.php line 361. You can now use child categories as checkbox. But remember, you can only use one parent to call the childs.

    Thank you πŸ™‚

    #30142

    Karel
    Member
    Post count: 9

    Thank you! Works fine now.

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Obligatory fields not working for taxonomy entry’ is closed to new replies.