Home Forums Plugin Support WP User Frontend Pro Plugin slows down server

This topic is: not resolved

This topic contains 22 replies, has 10 voices, and was last updated by  Sekander Badsha 4 years, 8 months ago.

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
    Posts
  • #24574

    Daniel
    Member
    Post count: 8

    I have struggled with my wordpress getting slow, and my client told me to get this sorted once and for all.
    After optimizing the site as much as I could, (minimizing js, html and css, as well as employing gzip and caching) the site still loaded very slowly (up to 7-9 seconds per page).
    I decided it must be a plugin that was the cause, and I found it was WP User Frontend Pro that slowed the system down – first with the google maps files that were loaded everywhere, so I removed that code. Second other scripts that kept being loaded on all pages so I dequeued them for normal pages.

    One would think this would be enough, but I still notice a drop of 50% in loading time when I deactivate the plugin.

    Any ideas

    #24593

    Joe F
    Member
    Post count: 12

    Same issue with the pro version. Had to deque scripts and style sheets from wpuf on normal pages. But it's still fairly slow. Any further advice anyone or wpuf team?

    Thanks.

    #24910

    Sekander Badsha
    Member
    Post count: 2067

    Hello Daniel and Joe,
    We have just recived this issue only from two of you. We have been using the plugin from the release time and never faced such issue. You can disable loading scripts on each page from the settings.
    Have you tested which scripts or precesses are eating the CPU or memory? You should check from your browser and from your server to be sure about what's causing you to slow down.

    #24917

    Daniel
    Member
    Post count: 8

    Well, no, you cannot disable ALL the scripts from the settings (most notably the google maps API calls).

    Unfortunately, I have had to move away from using this plugin. When I uninstalled it and deleted the plugin files I managed to cut down the server waiting time (time to render on the server). It came down from around 3-6 seconds to around 800 ms – 1.5 seconds.

    It is too bad, but hopefully in the future I can start using the plugin again.

    #25068

    Roxanne
    Member
    Post count: 24

    I am also facing the slow down issue. Is there any recommendations?

    #25326

    Tareq Hasan
    Keymaster
    Post count: 2831

    It's really hard to say whats actually creating the problems. It had performance issues on a very early version, but since then it improved a lot in terms of speed and features. Personally I am not sure what might cause this, but JS/CSS might be an issue. But certainly it's not a big one. Once a page is loaded, your browser caches the assets and the site becomes faster. In the plugin settings, you can disable the “Load Scripts” setting so that it will enqueue all the scripts in every pages.

    #26605

    Oliver
    Participant
    Post count: 1

    Hi,

    on the same note about “Load scripts/styles in all pages”.
    When you disable this option nothing happens. The plugin still loads everything on all pages.
    I got an average load time of 20ms without the plugin and this brings it up to 700ms. Really a deal breaker.
    I'm using the latest plugin version 2.2.4 on WordPress 3.9
    Is it possible to resolve this without editing the plugin itself?

    Thanks,
    Oliver

    #26615

    Dominik
    Member
    Post count: 14

    Same problem here. website got really slow after the plugin installation.

    #26616

    Roxanne
    Member
    Post count: 24

    I am also still facing speed issues. After deactivating the plugin my speed increase by 10 points in Google Page Speed.

    #26698

    Sekander Badsha
    Member
    Post count: 2067

    Hello All,
    I understand your problems and notified the developer team. They'll try their best to decrease the loading time.

    #26909

    Francisco
    Member
    Post count: 16

    I am also facing the slow down issue.

    In order to help community I recommend install “query monitor” plugin and see what happens. https://wordpress.org/plugins/query-monitor/

    It helps a lot, waiting news for the Dev team 😉

    Regards

    #27077

    Sonia
    Member
    Post count: 5

    Hi all,

    I found the same problem some weeks ago, and disabling “Load scripts/styles in all pages” didn't work either.

    In the meanwhile (waiting for a Wedevs solution), I managed somehow to speed-up the site with the following tip:

    – Edit functions.php file (make sure that you are using your child theme functions file!!!) and conditionally dequeue wpuf css & js in main pages (no wpuf shortcode was used in).

    This is only a patch, as css and scripts continue loading in the rest of pages/posts, but at least frontpage and main pages are not being affected.

    Wedevs team, please a quick and complete solution is needed.

    #27377

    Sekander Badsha
    Member
    Post count: 2067

    Hello Sonia,
    Have you tried with a default theme of WordPress (like- twenty fourteen) and all plugins except User Frontend disabled? We tried several times to reproduce the issue but failed. This issue is reported by 5 people only. We will have a look again.

    And please let me know if you have tried the above and what is the result.

    #27576

    Roxanne
    Member
    Post count: 24
    This reply has been marked as private.
    #27597

    Francisco
    Member
    Post count: 16

    Why Roxanne reply is market as private?

    Sekander Badsha(and entire Wedevs team):

    we feel as we don't have support. I have waiting 1 week to get a reply from support team
    The customers are acting as support and we pay a support that never comes or is really really insufficient.

    If you don't put the things right, you are about to lose so many customers, and future customers that are thinking about this. And without customers this plugin is not sustainable.

    Regards
    Frank

Viewing 15 posts - 1 through 15 (of 23 total)

The topic ‘Plugin slows down server’ is closed to new replies.