This topic contains 10 reply and 3 voices, and was last updated by Michael Chung Yeung 5 years, 4 months ago
Viewing 10 Posts - 1 through 10 (of 10 total)
Author Posts
May 5, 2014 at 2:26 pm 19902
Michael Chung Yeung I've enabled the image upload in post area option. Things work fine in my local development environment but it doesn't work in my staging server environment. Specifically, I got the usual pop-up window to select an image to upload after clicking the "Insert Photo" button, but the progress bar just opens up (above the text area) and just stays there (without any actual upload progress). FYI, i'm able to upload image with the Featured Image field. It's only the "Insert Photo" into post area button that doesn't seem to work. Any idea why?
May 5, 2014 at 3:04 pm 19906
Michael Chung Yeung Michael Chung Yeung

Just to follow up; turns out the photos have been successfully uploaded onto my staging server; it’s just that the photo doesn’t show up in the textarea and the progress bar just stays there, hence leading me to think wrongly that the image wasn’t uploaded properly.

Any idea how to fix this so that the image shows up in the text area?

May 5, 2014 at 3:25 pm 19910
Oritro Ahmed Oritro Ahmed

Hello Michael,

Which browser you are using?

This kind of problem often happen because of another plugin. Do you have any other plugin that relate to file upload, image gallery, or any Extra Widget on the theme?

These kind of plugin insert their own javascript into the theme, which often causes conflict with our plugin.

May 5, 2014 at 5:03 pm 19920
nery nery

Same problem here. Browser Firefox 29.0, Chrome 34.0.18747.131 m, Internet Explorer 11.0
All other plugins not active, Theme not modified. Same problem with 3 different themes.
I can reproduce the error on your demo environment:
http://demo.wedevs.com/wpuf/testing-photo-insertion/

May 5, 2014 at 7:31 pm 19924
Michael Chung Yeung Michael Chung Yeung

Exactly the point as @nery mentioned; the same error can be seen in your demo environment too!

http://demo.wedevs.com/wpuf/testing-photo-insertion/

Thing is I have the same plugins activated for both my staging server and my local development environments; works on my local but not on my staging server. And then I realised the only difference is that my local is still running wordpress 3.8, while my staging is running wordpress 3.9

So I updated my local to wordpress 3.9, and now the insert photo function is having the same problem as my staging server. So I’m pretty sure it’s a compatibility issue with wordpress 3.9

Assume this is an issue that needs to be fixed by wedevs?

May 5, 2014 at 10:08 pm 19927
Oritro Ahmed Oritro Ahmed

Hello Again,

Micheal, Seems like you are right. 3.9 Does have some upload issue. Its been notified to our developer team. They will jump into this ASAP.

May 6, 2014 at 6:40 am 19947
Michael Chung Yeung Michael Chung Yeung

Thanks, please let us know once this has been fixed.

May 6, 2014 at 11:55 am 19950
Oritro Ahmed Oritro Ahmed

Sure thing

May 6, 2014 at 1:35 pm 19963
Oritro Ahmed Oritro Ahmed

Okey, Our Developer team solved the problem. But you have to do a little bit of work.

Go to WP user front end pro plugin folder ( WordPress Root/wp-content/plugins/wp-user-frontend-pro/ ). You will see a folder named js. Inside that folder, you will find several js file. find frontend-form.js. Replace that file this one,

https://dl.dropboxusercontent.com/u/72669879/weDevs/frontend-form.js

Download this new file, and replace the previous one with this. Your problem should be fixed.

May 6, 2014 at 7:40 pm 19989
nery nery

Replaced file.
Upon click on “insert photo” the page jumps to the top. Nothing happens. Chrome. WP 3.9

May 7, 2014 at 6:09 pm 20071
Michael Chung Yeung Michael Chung Yeung

it’s working for me…thanks.

Viewing 10 Posts - 1 through 10 (of 10 total)