This topic contains 8 reply and 2 voices, and was last updated by Hannah 5 years, 6 months ago
Viewing 8 Posts - 1 through 8 (of 8 total)
Author Posts
April 3, 2014 at 2:58 pm 17918
Hannah Hi there, this plugin is mostly working brilliantly, but sometimes when you try to view a post, you get redirected to the site home page instead. This happens when users submit a post via a form within a wpcourseware unit page. This does NOT happen all the time! For a while, it's been working fine, then today, for no apparent reason, it's not saving the posts properly. It says 'post saved' but you just get redirected to the home page when you want to view it. This is the case even if you view the post from the wp dashboard and click 'view post'. You can see the post is there in the wp dashboard but when you press 'view post' you get redirected to the home page of the website. This happened once before a couple of months ago and I had to create a new form which I then put into the wpcourseware unit pages and that has worked fine up until today. I've tried creating a new form but within wp coursware unit pages, I'm getting the same error. The same form works fine on a normal wordpress page. Any ideas? Thanks, Hannah
April 3, 2014 at 3:14 pm 17924
Mahi Mahi

on your Wp User Frotnend Form there is an option – post settings

You can control the redirection from there. Please check you setup that correctly.

April 3, 2014 at 3:40 pm 17936
Hannah Hannah

Thank you for your reply. This is set up correctly. Even when I choose ‘redirect to newly created post’ it still takes me to the site home page as soon as you press submit. There is no way to view the created post at all.
I’ll also ask the wocourseware guys because there’s obviously some conflict between the plugins. It’s just frustrating when it has been working fine as it’s really nice to have the forms within the course unit pages.

April 3, 2014 at 4:46 pm 17949
Mahi Mahi

its really annoying as you said it was working fine! have you updated any plugin/theme recently which may cause the conflict?

April 11, 2014 at 3:04 pm 18506
Hannah Hannah This reply has been marked as private.
April 17, 2014 at 3:23 am 18905
Hannah Hannah

hey, is anyone there to help me on this? The form Training Journal Entry suddenly stopped working too. I have replaced it with a new form which is working for now. But, it’s still impossible to view any entries entered via the form during the period it wasn’t working – they are there in the wp dashboard under posts but it’s impossible to see them, even if you press ‘preview’ or ‘view post’ or copy the address into your browser – they all simply redirect you to the homepage.
I really need to find out what’s causing the forms to break – any help would be much appreciated!
Hannah

April 17, 2014 at 6:04 am 18912
Mahi Mahi

Hi Henna,

I just posted a test post and its visible at front-end.

link: http://connectiontraining.com/testing-6/

I used this form: http://connectiontraining.com/ct-home/courses/getting-started-reflections-and-experiences-module-1/

Also, i think you are controlling some permission stuffs with other plugin? Any chance that is conflicting?

April 17, 2014 at 1:58 pm 18925
Hannah Hannah

Hi thank you for your post! That’s so strange… I have no idea why it sometimes works and sometimes doesn’t. It’s a membership site controlled by paid memberships pro but everyone, even admins, have problems when it’s not working. It’s driving me crazy with this intermittent problem!

Is there a way to fix posts which redirect to the homepage?
There’s one here which was entered into a form by a member which redirects to the homepage. As you can see, it’s there in the dashboard but you can’t view it: http://connectiontraining.com/wp-admin/post.php?post=11575&action=edit&message=1

Thanks, Hannah

April 24, 2014 at 2:09 pm 19333
Hannah Hannah

This issue is happening again. I have narrowed it down so there is only one form on my site – sometimes it works, sometimes it doesn’t. I could really do with some help here!
Here are links to 2 posts written by members of my site in the last 24 hours using the same form:
This one works: http://connectiontraining.com/round-the-round-pen/
This one redirects you to the homepage: http://connectiontraining.com/module-1-reflections-4/
I really need to resolve this!
Thanks, Hannah

Viewing 8 Posts - 1 through 8 (of 8 total)