Home Forums Plugin Support WP User Frontend Pro Registration Form textfield not authenticating correctly

This topic is: resolved

This topic contains 14 replies, has 3 voices, and was last updated by  paperweight 6 years, 1 month ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #3371

    paperweight
    Participant
    Post count: 122

    I am having major problems with “Registration Forms” the past 2 days and I have seen no solution so I ask for your help:

    I had a textfield called “Your Job Title” and it was mandatory. On the frontend, when user completes registration form, the user correctly enters data into the “Your Job Title” field. However, when user submits, it says the user did not enter any data… OS i tested a lot and could not fix this.

    I finally deleted the “Your Job Title” textfield, but the Regsitration Form **still** says the user must enter that data — the field is no more in the page, and I am using new browsers without server/WP or browser cache… any idea why this is happening and how to fix it?

    I am stuck on this and can not login/register to test anything else until I fix how to get inside the site ๐Ÿ˜‰

    #3372

    Mahi
    Member
    Post count: 1555

    perhaps it not related with that field at all ? are you using any Captcha ?

    any chance we can check it in live ?

    #3373

    paperweight
    Participant
    Post count: 122

    Hi, it is on a live server but you need to change your Hosts files to see it correctly since it is a duplicate website of a live site. I will pass you the details and you can change your local computer Hosts, ok? Is there a way for me to email you the details so they are not displayed on this forum?

    #3374

    Mahi
    Member
    Post count: 1555

    you can reply here by “set as private reply” or email – support at wedevs dot com

    #3379

    paperweight
    Participant
    Post count: 122
    This reply has been marked as private.
    #3402

    paperweight
    Participant
    Post count: 122

    Hi, did you take a look at that yet? Let me know your thoughts~

    #3403

    Mahi
    Member
    Post count: 1555

    unfortunately, i wasn't able to login. its showing error and getting me back to main site.

    #3404

    paperweight
    Participant
    Post count: 122

    Then you are seeing the “live” website. You should instead visit the beta/development website.

    Did you change your computer's Host file and flush your dns cache? it sounds like this was not done correctly. Please use the info to change your Hosts file. After you do that (it takes 15 seconds to change on a PC or Mac) you should correctly be able to see the beta website.

    #3405

    paperweight
    Participant
    Post count: 122
    This reply has been marked as private.
    #3408

    paperweight
    Participant
    Post count: 122

    Also, I have the PRO version. I just noticed you have a separate forum for PRO comments, so please move this there if you think it is necessary ๐Ÿ™‚

    #3412

    paperweight
    Participant
    Post count: 122

    Ah, I found the problem. It was a major conflict again with Theme My Login. I changed and deleted some info in Theme My Login and WPUF works fine now. Solved!

    #3414

    Tareq Hasan
    Keymaster
    Post count: 2831

    Huh, I just changed my host file for testing!!

    #3416

    paperweight
    Participant
    Post count: 122

    Sorry about that Tareq ๐Ÿ˜‰

    The problem is with Theme My Login's optional configuration files that reside in /wp-content/plugins/theme-my-login-custom.php outside the main Theme My Login directory. Even if that file is NOT activated as aPlugin, it STILL creates conflict with WPUF. So I deleted that file and now WPUF authenticates fine.

    Longterm, I am unsure if this is a good or a bad thing. I would like to NOT use Theme My Login and instead only rely on WPUF~

    #3419

    Tareq Hasan
    Keymaster
    Post count: 2831

    I liked Theme My Login when it was cool. But the newer version of the plugin, I don't like really at all. I am also thinking to add login option to my plugin.

    #3420

    paperweight
    Participant
    Post count: 122

    Yes please!

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Registration Form textfield not authenticating correctly’ is closed to new replies.