Home Forums Plugin Support WP User Frontend Pro Seeing WPUF Custom Fields box on wrong post type

This topic is: not resolved

This topic contains 4 replies, has 4 voices, and was last updated by  Tareq Hasan 5 years, 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3166

    studioleland
    Participant
    Post count: 3

    I keep getting a “please fill out this field” error when updating pages (creating seems to be fine). This keeps me from updating any pages after creating them without filling in the custom fields but they are not specified to have any custom fields. I have a separate post type for submissions and that works fine. The normal “page” post type should not have this box appearing. I have checked settings several times where else should I look?

    #3170

    Tareq Hasan
    Keymaster
    Post count: 2831

    Is there someway you are selecting any Form from the “WPUF Form” sidebar metabox while creating pages? I don't have a clue what might cause this.

    #3427

    paperweight
    Participant
    Post count: 122

    Is maybe Theme My Login conflicting here? It sounds similar to the type of problem I had and fixed here.

    #4059

    rocketseven
    Participant
    Post count: 34

    Hello

    Same problem here. I´ve created one form and then created a page (“edit”) to edit the form. Inserted the shortcode [wpuf_edit] in that page and hit publish. Saw the created page and has expected i received the error “I don’t know how to edit this post, I don’t have the form ID”.

    Following the instructions on the documentation page, i returned to my “edit” page and selected the form from the meta box “WPUF Form”. I also selected that form in the individual posts page. When i hit “update” on my “edit” page, i also keep getting a “please fill out this field” error when updating. The page doesn't update no longer and it has to be deleted.

    I really don´t understand whats happening. Any ideas?

    Thank you for your help.

    Best

    #4071

    Tareq Hasan
    Keymaster
    Post count: 2831

    To setup the edit page, follow the instructions:

    1. Create a page, for example: Edit.
    2. Insert the shortcode [wpuf_edit] in the page.
    3. Go to plugin Settings > General Options > Edit Page. Select the page your just created which contains the shortcode [wpuf_edit]

    You don't have to select the “WPUF Form” for the edit page. Those are for the posts that has been created from the admin panel.

    Q. I get the message: “I don’t know how to edit this post, I don’t have the form ID”

    Ans: When you create a post with the new version of WP User Frontend, a form ID is being attached to that post. It’s needed because you might have 10 forms and it doesn’t know which form should be used to edit that post.

    For this problem with older posts, one thing you need to do. If you go the those posts edit screen in backend, you’ll see a meta box “WPUF Form”, select the form that should be used to edit the form.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Seeing WPUF Custom Fields box on wrong post type’ is closed to new replies.