Home Forums Theme Support Dokan Seller dashboard: Settings not updating

This topic is: not resolved

This topic contains 6 replies, has 2 voices, and was last updated by  towhid 3 years, 11 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #52188

    Steven
    Member
    Post count: 11

    Hi all,

    We have purchased and installed the Dokan extension for WordPress but are encountering a pesky problem in the Seller dashboard.

    On our local testing environment (using XAMPP, same PHP version etc. as on our live server) everything works fine. However, once everything is migrated to the live server environment the following (sub)pages stop updating information in the seller dashboard:
    Settings > Store
    Settings > Payment
    Settings > Social Profile

    We have tried enabling/disabling all other plugins one by one but to no avail. We have also checked and verified the permalink settings.

    A screen recording of the functionality on our local environments: http://recordit.co/d2VDRSwhlL

    And a recording of the live environment: http://recordit.co/fVBGcixKrP

    We have tried editing the vacation message field of the Dokan Seller Vacation add-on but none of the other fields (address, store name, profile picture,โ€ฆ) work either.

    Note that also the seller dashboard menu is different, although no changes have been made to any files or database entries prior or after migrating to the live environment.

    Thanks in advance for the help!

    #52215

    towhid
    Participant
    Post count: 4505

    Hello Steven,

    Please navigate to Settings->General-WordPress Address (URL) = Live url and Site Address (URL) = Live url and set permalinks as postname and product and see what happen. Here is the screenshot.

    Site Details

    Thank you ๐Ÿ™‚

    #52262

    Steven
    Member
    Post count: 11

    Hello towhid,

    On our localhost everything works fine.
    The problem occurs on our live server.
    The domain name is winkln.be, the WordPress Address and Site Address are both set to http://winkln.be and the permalink settings are set to postname and product, same as on our localhost.

    The file template-settings.php in /wp-content/plugins/dokan/classes is not executing correctly. The seller profile progress bar, also controlled by this script, does not function properly either.

    Hope this helps to clarify the issue.

    #52289

    towhid
    Participant
    Post count: 4505

    Hello Steven,

    I have tried to reproduce this issue but failed. Make sure you had properly configured Dokan settings. If the issue still persists then check for your theme or plugin conflicts.

    You can disable all your plugins except Dokan and switch to a default theme of WordPress like – Twenty Twelve, Twenty Thirteen, Twenty Fourteen and let me know the results.

    Thanks

    #52297

    Steven
    Member
    Post count: 11

    Hi again,

    Dokan settings have been properly configured.
    When switching to Twenty Fifteen everything works correctly.

    We have tried disabling all the plug-ins except for WooCommerce and Dokan but to no avail.

    Next, we reviewed our theme once more and deleted all non-vital code (basically just leaving us with the most simple version of a WordPress theme possible). But unfortunately the error still persists when our custom theme is activated.

    We really are at a loss for possible causes since the problem does not occur on our local development environment. We have, however, replicated the issue on two separate live server environments, hosted in two separate data centers.

    Thanks again

    #52352

    towhid
    Participant
    Post count: 4505

    Please provide your login details by using this form: http://wedevs.com/provide-login-details/. I will have a look what is going wrong.

    Thank you ๐Ÿ™‚

    #52496

    towhid
    Participant
    Post count: 4505

    Hello Steven,

    I have checked everything in Settings > Store, Payment and Social Profile page. I can update any thing in this three pages' available fields. Can you please clear your browser cache then try to update and let me know the result.

    Thanks

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Seller dashboard: Settings not updating’ is closed to new replies.