Home Forums Plugin Support WP Project Manager Pro System Emails Send Incorrect Project Links

This topic is: not resolved

This topic contains 9 replies, has 2 voices, and was last updated by  Nayem 4 years, 2 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #38371

    Aaron
    Member
    Post count: 4

    Hello,
    I have just noticed this. When the system sends out emails with the %PROJECT_NAME% code it takes the recipient to the admin area NOT the short coded page.

    Sample URL: http://authorplatform.guru/wp-admin/admin.php?page=cpm_projects&tab=project&action=single&pid=701

    When it should go to the specific project page: http://authorplatform.guru/your-project/?project_id=701 or, at the very least the main project page: http://authorplatform.guru/your-project/

    Yes, I know I can change this in WPPMP in “Email Settings” but then I can only send it to the main page, not the specific project (because there will be multiple projects.

    Any hope of this changing?

    #38442

    Nayem
    Moderator
    Post count: 6480

    Hello Aaron,

    I have to discuss with my developer team. They are now in weekend. I will come back to you after the discussion with them tomorrow.

    Thank you ๐Ÿ™‚

    #38893

    Aaron
    Member
    Post count: 4

    Thanks! I look forward to a resolution.
    I have been playing around with the code to see if I could resolve it myself. More complicated than I would have guessed!

    #38928

    Nayem
    Moderator
    Post count: 6480

    Hello Aaron,

    Can you please provide a screenshot with more details of your problem?.

    #39040

    Aaron
    Member
    Post count: 4

    I will send a screenshot via email (as I don't see a way to attach it here).

    Basically, the issue is that in having the Pro version I can add shortcodes to pages so that the end user gets to see the “pretty” page – the project embedded in the WP theme as you see here: http://authorplatform.guru/your-project/?project_id=701

    However, when I add an item (task, message, to-do, etc) the system emails send a link like this: http://authorplatform.guru/wp-admin/admin.php?page=cpm_projects&tab=project&action=single&pid=701 which sends the end user to the project but in the admin area (screenshot coming).

    #39111

    Nayem
    Moderator
    Post count: 6480

    Hello Aron,

    Please upload your screenshot anywhere in the web and give me the link here. Did you install Project manager fronted add-on?.

    #39312

    Aaron
    Member
    Post count: 4
    #39432

    Nayem
    Moderator
    Post count: 6480

    Hello Aaron,

    I have to discuss with our developer team about this. Please allow me some time.

    Thank you ๐Ÿ™‚

    #39650

    Aaron
    Member
    Post count: 4

    Basically, the issue is that in having the Pro version I can add shortcodes
    to pages so that the end user gets to see the “pretty” page – the project
    embedded in the WP theme as you see here:
    http://authorplatform.guru/your-project/?project_id=701

    However, when I add an item (task, message, to-do, etc) the system emails
    send a link like this:
    http://authorplatform.guru/wp-admin/admin.php?page=cpm_projects&tab=project&
    action=single&pid=701 which sends the end user to the project but in the
    admin area (screenshot coming).

    Aaron C. Yeagle, Internet Consultant
    951.251.5767
    aaron@your.pro

    From: weDevs Team
    Reply-To:

    Date: Wednesday, March 11, 2015 at 10:35 PM
    To: Aaron Yeagle
    Subject: Re: [weDevs] System Emails Send Incorrect Project Links

    Nazmul Hassan Nayem wrote:

    Hello Aaron,

    Can you please provide a screenshot with more details of your problem?.

    #39662

    Nayem
    Moderator
    Post count: 6480

    Hello Aaron,

    I have already forwarded this issue to our developer team.

    Thank you ๐Ÿ™‚

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘System Emails Send Incorrect Project Links’ is closed to new replies.