Home Forums Theme Support Dokan Unable to standardise vendor template and attributes selection keeps hiding

This topic is: resolved

This topic contains 24 replies, has 3 voices, and was last updated by  JESLYN 4 years, 7 months ago.

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #26292

    JESLYN
    Member
    Post count: 46

    Hi there,

    2 issues here :

    I've gone thru your forum but can't seems to find a remedy to the above issue mentioned. And apparently in Dokan's demo, both has the same issues.

    1) Is there any ways whereby I can standardise the sizes in vendors' list page? Doesn't look very professional and rather messy to have big and small template sizes.

    http://www.eshopaholics.sg/vendors/

    2) After the latest Dokan updates, when I'm trying to create New Product, the selections (Custom attribute / Add a category / Save attributes) under “Attributes” tab keeps hiding by itself. User has to mouse over before the selections come out.

    I have cleared all my cookies etc but the same thing still happens.

    Kindly advise how to go about it.

    Thanks in advance.

    #26385

    Sekander Badsha
    Member
    Post count: 2067

    Hello Jeslyn,
    1. You can set the height and width of the images with CSS.
    2. This issue is not clear to me. Can you please send me some screenshots?

    #26508

    JESLYN
    Member
    Post count: 46

    Hi Sekander,

    1) Possible to advise which line in CSS is the one that I can adjust the height & width?

    2) Image for hidden attributes buttons as per requested :

    buttons hiding

    3) Btw, just noticed that there's a new issue (happens only after the update) – Unable to add variations after confirming the attributes.

    These are the attributes that I'm adding (rental & colors):

    attributes page

    But when I'm at the variation page, regardless of which selections I clicked on, I can't create any variations :

    0 variations added

    Not even manually. The numeric 0 keeps appearing when i select “Add Variation”

    variations appeared as 0

    Btw I did not make any changes in the editor and these only happens after the latest Dokan update. Hence would appreciate if you could look into it before other users face the same issues too ๐Ÿ™‚

    #26584

    Sk
    Moderator
    Post count: 371

    Hi,

    It's working perfectly here. check the image

    http://awesomescreenshot.com/0b43glvk4f

    please check your browser settings.

    thank you

    #26633

    JESLYN
    Member
    Post count: 46

    Hi Shaikat,

    I've checked my browser settings (views are set actual size too) but still couldn't rectify the issue *sigh*. Anyway, since you are able to do a full view without any buttons hiding, I hope it's gonna be fine for my vendors.

    By the way, kindly advise on issue 1 and 3 since till date I'm still stuck with it and can't find any no solution threads in the forum.

    Thanks.

    #26636

    JESLYN
    Member
    Post count: 46

    Hi Shaikat,

    I just did a testing on the 3rd issue – “variations” and realised that it's working well now. Many thanks.

    Only remaining is the first issue – appreciate your advise on where's the exact line that I gotto edit, in order to standardise the vendor's template outlook.

    >> http://www.eshopaholics.sg/vendors/

    Thanks ๐Ÿ™‚

    #26652

    JESLYN
    Member
    Post count: 46

    And also in addition to the above issue 1, another new issue :

    Possible to advise where'd gone wrong, under “My Orders” page. This happens after I have updated the latest WooCommerce 2.2.0 version:

    Error Message as shown below :

    error message

    Thanks!

    #26658

    JESLYN
    Member
    Post count: 46

    Sorry again, I understand that my thread is kinda a lot but this is driving me nuts.

    I went to re-install Dokan (advise as per instructed in your forum to other users) due to my “Reviews” and “Reports” page not linking to the exact page. Issue still not yet fixed and the “Variation” problem comes again. *grrrr*

    So in total, please advise me how to go about this so that I can rectify the issue myself in the future, in case of any further updates? :

    1) Vendors' banner aligning issue

    2) Error message that keeps appearing in “My Orders” page (image as per shown in above thread)

    3) “Reviews” and “Reports” forms directed to other links instead

    4) Variation issue – AGAIN.

    #26770

    Sk
    Moderator
    Post count: 371

    Hi,

    May be you have conflict in your site. please provide your site access in a private message. we would like to check the issue.
    thank you.

    #26806

    JESLYN
    Member
    Post count: 46
    This reply has been marked as private.
    #26830

    Sk
    Moderator
    Post count: 371

    issue 1: navigate to dokan/style.css on line 1735. .seller-listing .thumbnail > a > img is the class for vendor images listing style.

    other issues are happening for woocommerce version. dokan theme is not fully compatible with woocommerce 2.2.2 version. dokan plugin is coming with all the updates.

    Thank you

    #26849

    JESLYN
    Member
    Post count: 46

    Hi Shaikat,

    Thanks for the checking and also advise on issue 1. I'll take note from next update onwards, for Woocommerce, to wait till Dokan has their new updates before I proceed with any updatings.

    In regards to Dokan next update, kindly advise on estimated timeline. As I'll be launching my site in Mid-Oct, am hoping that it can run smoothly by then.

    #27789

    JESLYN
    Member
    Post count: 46

    Hi there,

    I've finally gotten the new updates from you guys, congrats! But apparently more issues are arising after the updates.. -_- I've already uninstalled the new Dokan plugin and reinstall everything back but still to no avail. Kindly assist.

    1) In our previous “vendor” image listing style, I wish to standardise the thumbnail so that it looks neat. However, the solution that Shaikat provided is no longer available. I'm unable to find the line and amend the thumbnail image myself now.

    2) Now, I'm unable to delete products from the sellers' dashboard and all products have to be deleted from backend?

    unable to delete products
    Link here in case you can't view : http://postimg.org/image/8pmjb6i93/

    3) As you can see, the unwanted sidebar at the seller dashboard keeps appearing regardless how many times I remove it from backend. This never happened to the older Dokan version

    unable to remove sidebar
    Link here in case you can't view : http://postimg.org/image/i9abujx0b/

    4) Alignments in “New Product” are all gone. Not sure if it's due to the sidebar issue. But well, fyi, I have checked my computer's view settings etc, everything is good.

    alignments gone

    alignments gone 2
    Links here in case you can't view : http://postimg.org/image/yb5x57gmn/ & http://postimg.org/image/qeelnhwln/

    5) Unable to run variations still. But this time round it's better – Only me (admin) is unable to add variations from frontend. I have tried to login as a seller to add variation for products and it worked. Could you kindly explain why? I would hope to be able to add variations as an admin from both front and backend.

    unable to run variations
    Links here in case you can't view : http://postimg.org/image/v6mknqbwp/

    #27880

    JESLYN
    Member
    Post count: 46
    This reply has been marked as private.
    #27882

    Sekander Badsha
    Member
    Post count: 2067

    Hello Jeslyn,
    1) Inspect the class of the image. You can get the current class of the CSS that image is using and the file where it is located. And then you can override the CSS from your theme or child-theme.

    2) This issue is fixed. You will get a new update within today. After the update you will be able to delete the products from frontend.

    3) Do you mean the images in the bottom? If yes, they might be coming from any of your plugin or your browser add-on. You can disable all your plugin except Dokan and WooCommerce and open your browser in incognito mode and see if the issue persists.

    4) and 5) should be fixed upon doing 3) if not, you have to inspect the CSS classes and might have to alter some margin and padding by CSS.

Viewing 15 posts - 1 through 15 (of 25 total)

The topic ‘Unable to standardise vendor template and attributes selection keeps hiding’ is closed to new replies.