Home Forums Plugin Support WP User Frontend Pro [wpuf_edit] shows wrong form

This topic is: resolved

This topic contains 7 replies, has 2 voices, and was last updated by  Jan 5 years, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #10239

    Jan
    Participant
    Post count: 3

    Hi,

    I've got WPUF pro running on a site, it's a really neat plugin. However, I have two forms, both of which edit a different custom post type.

    My Dashboard is separated to show a list of the different posts using:

    [wpuf_dashboard post_type=”directory”] and then [wpuf_dashboard post_type=”offers”]

    If I click “edit” on the directory posts the edit form appears as expected. However, if I do the same on the “offers” posts I get the same form as for editing the directory instead of the one assigned to “offers” posts.

    Have I missed something in the setup?

    Thanks

    #10250

    Mahi
    Member
    Post count: 1555

    possible to share login details to check this issue further? cause, it shouldn't behave like this. All you have to do – create a single edit page and it should pick all custom fields/types by it self!

    Please provide your site url, user login and password so we can check it. Also mark your reply as Private reply to keep it safe.

    #12602

    Jan
    Participant
    Post count: 3
    This reply has been marked as private.
    #12617

    Mahi
    Member
    Post count: 1555

    Hello Jan,
    You just found a bug! Looks like we did a small mistake on last update version!
    I will give you the solution with in couple of hours.
    Sorry for inconvenience.

    #12627

    Mahi
    Member
    Post count: 1555

    hello Jan,

    Sorry my apology. It was configuration error!

    Issue was – you didn't create a page with Directory form code and i think the post was there created from backend. So, no form was assigned in to that post. So, when you tried to edit that form it tried to use default one select from settings area.

    I create a new page ” Add Directory Listing” and submitted a directory post. Now, its all good as it should.

    Please login with the username you gave me and check your self.

    #12630

    Jan
    Participant
    Post count: 3
    This reply has been marked as private.
    #12631

    Mahi
    Member
    Post count: 1555

    Thats what i said ๐Ÿ™‚
    cause, that directory post was created before you install this plugin or from admin backend area!
    Create any new directory post by using wpuf form it should be just fine.

    #12633

    Jan
    Participant
    Post count: 3

    Ah OK I understand.

    So unless the post is created through WPUF then the form doesn't display when editing, but displays the fallback form set in the settings area of the plugin.

    For this site directory entries are created using Gravity Forms as it's part of longer pre-existing process. So I've set this form as the default. Offers will only ever be created through WPUF so that works fine. I just need to make sure I use WPUF forms in the future for creating posts.

    Thanks,

    Jan

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘[wpuf_edit] shows wrong form’ is closed to new replies.