Home Forums Plugin Support WP User Frontend Pro wpufpro and theme my login

This topic is: resolved

This topic contains 1 reply, has 2 voices, and was last updated by  Tareq Hasan 5 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #6982

    Post count: 10

    (Forgive the duplicate on this…didn't realize the other post was in the free version's forum.)

    I'm having just a horrible time in getting wpufpro to work with theme my login. I really wish there was someone that had a step by step setup process that showed exactly what pages I needed to create and what shortcodes needed to be in each of those pages. I fix one problem only to have another appear.

    On the log in screen using Theme My Login, there are two links below the username and password entry fields: “Register” and “Lost Password”.

    When “Registration link override” is NOT checked in wpufpro settings, the “register” links to the Theme My Login registration (not desired because I have a custom form created with wpufpro) and the “lost password” link correctly directs to the /lostpassword page.


    When “Registration link override” IS checked, the “register” link now correctly links to the wpufpro registration form, but the “lost password” link directs back to the /login page.

    Either way “registration link override” is checked, one of the links in user log in does not work and there is no setting in theme my login to customize these links.



    Tareq Hasan
    Post count: 2831

    Hi sorry for replying late, I can confirm that this is a bug. You can quick fix it by putting return $url; after line 266 in wpuf.php. So this would look like this:

    function override_registration_tml( $url, $action ) {
    if ( wpuf_get_option( ‘register_link_override', ‘wpuf_profile' ) != ‘on' ) {
    return $url;

    if ( $action == ‘register' ) {
    return get_permalink( wpuf_get_option( ‘reg_override_page', ‘wpuf_profile' ) );

    return $url;

Viewing 2 posts - 1 through 2 (of 2 total)

The topic ‘wpufpro and theme my login’ is closed to new replies.